
<!DOCTYPE html>
<!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]--><!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]--><!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]--><!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]--><!--[if (gt IE 9)|!(IE)]><!-->
<html class="no-js" dir="ltr" xmlns="http://www.w3.org/1999/xhtml" xmlns:b="http://www.google.com/2005/gml/b" xmlns:c="http://s.opencalais.com/1/pred/" xmlns:ctag="http://commontag.org/ns#" xmlns:data="http://www.google.com/2005/gml/data" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:dcterm="http://purl.org/dc/terms/" xmlns:expr="http://www.google.com/2005/gml/expr" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioctypes="http://rdfs.org/sioc/types#" xmlns:v="http://rdf.data-vocabulary.org/#" xmlns:meebo="http://www.meebo.com" xmlns:addthis="http://www.addthis.com/help/api-spec" itemscope itemtype="http://schema.org/Blog" lang="en-US"><!--<![endif]-->
<head profile="http://gmpg.org/xfn/11">
<script src="/cdn-cgi/apps/head/AtmWmoozrQ5epw_85tNGK6N6zTE.js"></script><script type="text/javascript">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</script>
<title>  #RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO) - Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News</title>
<meta name="robots" content="index,follow" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta content="Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" name="description" />
<meta name="y_key" content="a253b756d4a876c5" />
<meta name="dmoz.id" content="" />
<meta property="twitter:account_id" content="14174554" />
<meta name="revisit-after" content="1 days" />
<meta name="rating" content="General" />
<meta name="classification" content="Weblog" />
<meta name="distribution" content="global" />
<meta name="MSSmartTagsPreventParsing" content="true" />
<meta name="author" content="ATLien" />
<meta name="google-site-verification" content="Vd1bL8T_A-b8076YudJJ2IbndwiRwXElhAqh3dlV4H4" />
<meta name="google-site-verification" content="v14OaPeUZU9C5AnL4MrJqsci05Fupa8MC_jE4E-1nwg" />
<meta name="google-site-verification" content="jU20Mb9_9KmsJQdSe2GcYvVbMkRwps5eNNcu2aKO56A" />
<meta name="keywords" content="ATLANTA gossip,phaedra parks,NeNe Leakes,fantasia barrino,celebrity gossip,urban gossip,Big Boi,Outkast,andre 3000,Atlanta,Atlanta Housewives,the real housewives of atlanta,Beyonce,kandi burruss,Rhianna,Ne-Yo,ludacris,cynthia bailey,rumors,sheree whitfield,phaedra parks,hip-hop,goodie mob,love and hip hop atlanta,77UIfg_LokXvsryzwoLDjhWxNBE" />
<meta name="verify-v1" content="aX4NgU4kvosERqQla4iWMtzN7/HOKCDPc+3FKKrbVzc=" />
<meta name="google-site-verification" content="sLJCSXVOSaUoODbIg7m2cCQniGLDv0u-8nDyc6sGyOU" />
<link href="http://straightfromthea.com/wp-content/themes/sfta/style.css" type="text/css" rel="stylesheet" />
<link rel="shortcut icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.ico" />
<link rel="icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.gif" type="image/gif" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://straightfromthea.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="http://straightfromthea.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 1.0" href="http://straightfromthea.com/feed/atom/" />
<link rel="pingback" href="http://straightfromthea.com/xmlrpc.php" />
<link rel='archives' title='July 2019' href='http://straightfromthea.com/2019/07/' />
<link rel='archives' title='June 2019' href='http://straightfromthea.com/2019/06/' />
<link rel='archives' title='May 2019' href='http://straightfromthea.com/2019/05/' />
<link rel='archives' title='April 2019' href='http://straightfromthea.com/2019/04/' />
<link rel='archives' title='March 2019' href='http://straightfromthea.com/2019/03/' />
<link rel='archives' title='February 2019' href='http://straightfromthea.com/2019/02/' />
<link rel='archives' title='January 2019' href='http://straightfromthea.com/2019/01/' />
<link rel='archives' title='December 2018' href='http://straightfromthea.com/2018/12/' />
<link rel='archives' title='November 2018' href='http://straightfromthea.com/2018/11/' />
<link rel='archives' title='October 2018' href='http://straightfromthea.com/2018/10/' />
<link rel='archives' title='September 2018' href='http://straightfromthea.com/2018/09/' />
<link rel='archives' title='August 2018' href='http://straightfromthea.com/2018/08/' />
<link rel='archives' title='July 2018' href='http://straightfromthea.com/2018/07/' />
<link rel='archives' title='June 2018' href='http://straightfromthea.com/2018/06/' />
<link rel='archives' title='May 2018' href='http://straightfromthea.com/2018/05/' />
<link rel='archives' title='April 2018' href='http://straightfromthea.com/2018/04/' />
<link rel='archives' title='March 2018' href='http://straightfromthea.com/2018/03/' />
<link rel='archives' title='February 2018' href='http://straightfromthea.com/2018/02/' />
<link rel='archives' title='January 2018' href='http://straightfromthea.com/2018/01/' />
<link rel='archives' title='December 2017' href='http://straightfromthea.com/2017/12/' />
<link rel='archives' title='November 2017' href='http://straightfromthea.com/2017/11/' />
<link rel='archives' title='October 2017' href='http://straightfromthea.com/2017/10/' />
<link rel='archives' title='September 2017' href='http://straightfromthea.com/2017/09/' />
<link rel='archives' title='August 2017' href='http://straightfromthea.com/2017/08/' />
<link rel='archives' title='July 2017' href='http://straightfromthea.com/2017/07/' />
<link rel='archives' title='June 2017' href='http://straightfromthea.com/2017/06/' />
<link rel='archives' title='May 2017' href='http://straightfromthea.com/2017/05/' />
<link rel='archives' title='April 2017' href='http://straightfromthea.com/2017/04/' />
<link rel='archives' title='March 2017' href='http://straightfromthea.com/2017/03/' />
<link rel='archives' title='February 2017' href='http://straightfromthea.com/2017/02/' />
<link rel='archives' title='January 2017' href='http://straightfromthea.com/2017/01/' />
<link rel='archives' title='December 2016' href='http://straightfromthea.com/2016/12/' />
<link rel='archives' title='November 2016' href='http://straightfromthea.com/2016/11/' />
<link rel='archives' title='October 2016' href='http://straightfromthea.com/2016/10/' />
<link rel='archives' title='September 2016' href='http://straightfromthea.com/2016/09/' />
<link rel='archives' title='August 2016' href='http://straightfromthea.com/2016/08/' />
<link rel='archives' title='July 2016' href='http://straightfromthea.com/2016/07/' />
<link rel='archives' title='June 2016' href='http://straightfromthea.com/2016/06/' />
<link rel='archives' title='May 2016' href='http://straightfromthea.com/2016/05/' />
<link rel='archives' title='April 2016' href='http://straightfromthea.com/2016/04/' />
<link rel='archives' title='March 2016' href='http://straightfromthea.com/2016/03/' />
<link rel='archives' title='February 2016' href='http://straightfromthea.com/2016/02/' />
<link rel='archives' title='January 2016' href='http://straightfromthea.com/2016/01/' />
<link rel='archives' title='December 2015' href='http://straightfromthea.com/2015/12/' />
<link rel='archives' title='November 2015' href='http://straightfromthea.com/2015/11/' />
<link rel='archives' title='October 2015' href='http://straightfromthea.com/2015/10/' />
<link rel='archives' title='September 2015' href='http://straightfromthea.com/2015/09/' />
<link rel='archives' title='August 2015' href='http://straightfromthea.com/2015/08/' />
<link rel='archives' title='July 2015' href='http://straightfromthea.com/2015/07/' />
<link rel='archives' title='June 2015' href='http://straightfromthea.com/2015/06/' />
<link rel='archives' title='May 2015' href='http://straightfromthea.com/2015/05/' />
<link rel='archives' title='April 2015' href='http://straightfromthea.com/2015/04/' />
<link rel='archives' title='March 2015' href='http://straightfromthea.com/2015/03/' />
<link rel='archives' title='February 2015' href='http://straightfromthea.com/2015/02/' />
<link rel='archives' title='January 2015' href='http://straightfromthea.com/2015/01/' />
<link rel='archives' title='December 2014' href='http://straightfromthea.com/2014/12/' />
<link rel='archives' title='November 2014' href='http://straightfromthea.com/2014/11/' />
<link rel='archives' title='October 2014' href='http://straightfromthea.com/2014/10/' />
<link rel='archives' title='September 2014' href='http://straightfromthea.com/2014/09/' />
<link rel='archives' title='August 2014' href='http://straightfromthea.com/2014/08/' />
<link rel='archives' title='July 2014' href='http://straightfromthea.com/2014/07/' />
<link rel='archives' title='June 2014' href='http://straightfromthea.com/2014/06/' />
<link rel='archives' title='May 2014' href='http://straightfromthea.com/2014/05/' />
<link rel='archives' title='April 2014' href='http://straightfromthea.com/2014/04/' />
<link rel='archives' title='March 2014' href='http://straightfromthea.com/2014/03/' />
<link rel='archives' title='February 2014' href='http://straightfromthea.com/2014/02/' />
<link rel='archives' title='January 2014' href='http://straightfromthea.com/2014/01/' />
<link rel='archives' title='December 2013' href='http://straightfromthea.com/2013/12/' />
<link rel='archives' title='November 2013' href='http://straightfromthea.com/2013/11/' />
<link rel='archives' title='October 2013' href='http://straightfromthea.com/2013/10/' />
<link rel='archives' title='September 2013' href='http://straightfromthea.com/2013/09/' />
<link rel='archives' title='August 2013' href='http://straightfromthea.com/2013/08/' />
<link rel='archives' title='July 2013' href='http://straightfromthea.com/2013/07/' />
<link rel='archives' title='June 2013' href='http://straightfromthea.com/2013/06/' />
<link rel='archives' title='May 2013' href='http://straightfromthea.com/2013/05/' />
<link rel='archives' title='April 2013' href='http://straightfromthea.com/2013/04/' />
<link rel='archives' title='March 2013' href='http://straightfromthea.com/2013/03/' />
<link rel='archives' title='February 2013' href='http://straightfromthea.com/2013/02/' />
<link rel='archives' title='January 2013' href='http://straightfromthea.com/2013/01/' />
<link rel='archives' title='December 2012' href='http://straightfromthea.com/2012/12/' />
<link rel='archives' title='November 2012' href='http://straightfromthea.com/2012/11/' />
<link rel='archives' title='October 2012' href='http://straightfromthea.com/2012/10/' />
<link rel='archives' title='September 2012' href='http://straightfromthea.com/2012/09/' />
<link rel='archives' title='August 2012' href='http://straightfromthea.com/2012/08/' />
<link rel='archives' title='July 2012' href='http://straightfromthea.com/2012/07/' />
<link rel='archives' title='June 2012' href='http://straightfromthea.com/2012/06/' />
<link rel='archives' title='May 2012' href='http://straightfromthea.com/2012/05/' />
<link rel='archives' title='April 2012' href='http://straightfromthea.com/2012/04/' />
<link rel='archives' title='March 2012' href='http://straightfromthea.com/2012/03/' />
<link rel='archives' title='February 2012' href='http://straightfromthea.com/2012/02/' />
<link rel='archives' title='January 2012' href='http://straightfromthea.com/2012/01/' />
<link rel='archives' title='December 2011' href='http://straightfromthea.com/2011/12/' />
<link rel='archives' title='November 2011' href='http://straightfromthea.com/2011/11/' />
<link rel='archives' title='October 2011' href='http://straightfromthea.com/2011/10/' />
<link rel='archives' title='September 2011' href='http://straightfromthea.com/2011/09/' />
<link rel='archives' title='August 2011' href='http://straightfromthea.com/2011/08/' />
<link rel='archives' title='July 2011' href='http://straightfromthea.com/2011/07/' />
<link rel='archives' title='June 2011' href='http://straightfromthea.com/2011/06/' />
<link rel='archives' title='May 2011' href='http://straightfromthea.com/2011/05/' />
<link rel='archives' title='April 2011' href='http://straightfromthea.com/2011/04/' />
<link rel='archives' title='March 2011' href='http://straightfromthea.com/2011/03/' />
<link rel='archives' title='February 2011' href='http://straightfromthea.com/2011/02/' />
<link rel='archives' title='January 2011' href='http://straightfromthea.com/2011/01/' />
<link rel='archives' title='December 2010' href='http://straightfromthea.com/2010/12/' />
<link rel='archives' title='November 2010' href='http://straightfromthea.com/2010/11/' />
<link rel='archives' title='October 2010' href='http://straightfromthea.com/2010/10/' />
<link rel='archives' title='September 2010' href='http://straightfromthea.com/2010/09/' />
<link rel='archives' title='August 2010' href='http://straightfromthea.com/2010/08/' />
<link rel='archives' title='July 2010' href='http://straightfromthea.com/2010/07/' />
<link rel='archives' title='June 2010' href='http://straightfromthea.com/2010/06/' />
<link rel='archives' title='May 2010' href='http://straightfromthea.com/2010/05/' />
<link rel='archives' title='April 2010' href='http://straightfromthea.com/2010/04/' />
<link rel='archives' title='March 2010' href='http://straightfromthea.com/2010/03/' />
<link rel='archives' title='February 2010' href='http://straightfromthea.com/2010/02/' />
<link rel='archives' title='January 2010' href='http://straightfromthea.com/2010/01/' />
<link rel='archives' title='December 2009' href='http://straightfromthea.com/2009/12/' />
<link rel='archives' title='November 2009' href='http://straightfromthea.com/2009/11/' />
<link rel='archives' title='October 2009' href='http://straightfromthea.com/2009/10/' />
<link rel='archives' title='September 2009' href='http://straightfromthea.com/2009/09/' />
<link rel='archives' title='August 2009' href='http://straightfromthea.com/2009/08/' />
<link rel='archives' title='July 2009' href='http://straightfromthea.com/2009/07/' />
<link rel='archives' title='June 2009' href='http://straightfromthea.com/2009/06/' />
<link rel='archives' title='May 2009' href='http://straightfromthea.com/2009/05/' />
<link rel='archives' title='April 2009' href='http://straightfromthea.com/2009/04/' />
<link rel='archives' title='March 2009' href='http://straightfromthea.com/2009/03/' />
<link rel='archives' title='February 2009' href='http://straightfromthea.com/2009/02/' />
<link rel='archives' title='January 2009' href='http://straightfromthea.com/2009/01/' />
<link rel='archives' title='December 2008' href='http://straightfromthea.com/2008/12/' />
<link rel='archives' title='November 2008' href='http://straightfromthea.com/2008/11/' />
<link rel='archives' title='October 2008' href='http://straightfromthea.com/2008/10/' />
<link rel='archives' title='September 2008' href='http://straightfromthea.com/2008/09/' />
<link rel='archives' title='August 2008' href='http://straightfromthea.com/2008/08/' />
<link rel='archives' title='July 2008' href='http://straightfromthea.com/2008/07/' />
<link rel='archives' title='June 2008' href='http://straightfromthea.com/2008/06/' />
<link rel='archives' title='May 2008' href='http://straightfromthea.com/2008/05/' />
<link rel='archives' title='April 2008' href='http://straightfromthea.com/2008/04/' />
<link rel='archives' title='March 2008' href='http://straightfromthea.com/2008/03/' />
<link rel='archives' title='February 2008' href='http://straightfromthea.com/2008/02/' />
<link rel='archives' title='January 2008' href='http://straightfromthea.com/2008/01/' />
<link rel='archives' title='December 2007' href='http://straightfromthea.com/2007/12/' />
<link rel='archives' title='November 2007' href='http://straightfromthea.com/2007/11/' />
<link rel='archives' title='October 2007' href='http://straightfromthea.com/2007/10/' />
<link rel='archives' title='September 2007' href='http://straightfromthea.com/2007/09/' />
<link rel='archives' title='August 2007' href='http://straightfromthea.com/2007/08/' />
<title>#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//k4z6w9b5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Feed" href="http://straightfromthea.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Comments Feed" href="http://straightfromthea.com/comments/feed/" />
<meta name="description" content="The Real Housewives of Atlanta may have a real life story to add to it&amp;#8217;s latest season. Porsha Williams&amp;#8217; baby daddy Dennis McKinley recently had a..." />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; #RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO) Comments Feed" href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/feed/" />
<meta name="keywords" content="Dennis McKinley, For Discussion, OPEN POST, Porsha Williams, Racial Profiling, WTF" />
<meta name="robots" content="index,follow,noodp,noydir" />
<link rel="canonical" href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/" />

<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script' />
<script data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/straightfromthea.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"http:\/\/straightfromthea.com\/wp-admin\/admin-ajax.php"},"url_components":{"year":"2019","monthnum":"07","day":"29","hour":"13","minute":"29","second":"34","post_id":"239590","postname":"rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video","category":"news"}};
  //]]>
</script>
<script data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='6138b4eb6e460dce4355a17f4f16ad8e' async>
</script>

<meta name='shareaholic:site_name' content='Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/' />
<meta name='shareaholic:keywords' content='dennis mckinley, for discussion, open post, porsha williams, racial profiling, wtf, atlanta gossip, news, post' />
<meta name='shareaholic:article_published_time' content='2019-07-29T13:29:34-04:00' />
<meta name='shareaholic:article_modified_time' content='2019-07-29T13:36:01-04:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='ATLien' />
<meta name='shareaholic:site_id' content='6138b4eb6e460dce4355a17f4f16ad8e' />
<meta name='shareaholic:wp_version' content='8.13.6' />
<meta name='shareaholic:image' content='http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-640x538.jpg' />

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/straightfromthea.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://straightfromthea.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css' href='http://straightfromthea.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='sheknows-infuse-css' href='http://straightfromthea.com/wp-content/plugins/sheknows-infuse/public/css/style.css?ver=1.0.20' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='http://straightfromthea.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://straightfromthea.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.5.3' type='text/css' media='all' />
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://straightfromthea.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://straightfromthea.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://straightfromthea.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)' href='http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://wp.me/p2F0SY-10km' />
<link rel="alternate" type="application/json+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2019%2F07%2F29%2Frhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2019%2F07%2F29%2Frhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video%2F&#038;format=xml" />
<script type="text/javascript">
	window._zem_rp_post_id = '239590';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = '%23RHOA+Porsha+Williams%27+Baby+Daddy+Racially+Profiled+By+Police...+%28PHOTOS+%2B+VIDEO%29';
	window._zem_rp_post_tags = ['dennis+mckinley', 'for+discussion', 'open+post', 'porsha+williams', 'racial+profiling', 'wtf', 'news', 'atlanta+gossip', 'social', 'william', 'univers', 'mckinlei', 'porsha', 'media', 'emori', 'rhoa', 'denni', 'walsh', 'housew', 'instagram', 'video', 'atlanta', 'babi'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'http://straightfromthea.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '5';
</script>
<link rel="stylesheet" href="http://straightfromthea.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical-m.css?version=1.14" />

<script type="text/javascript">
	var blogherads = blogherads || {};
	blogherads.adq = blogherads.adq || [];

	
	
	
		blogherads.adq.push(function () {
								blogherads.setTargeting("ci", 239590);
								blogherads.setTargeting("pt", "post");
								blogherads.setTargeting("tags", ["dennis-mckinley","for-discussion","open-post","porsha-williams","racial-profiling","wtf"]);
								blogherads.setTargeting("ch", ["atlanta-gossip","news"]);
			});
	</script>
<script type="text/javascript" async="async" data-cfasync="false" src="https://ads.blogherads.com/static/blogherads.js"></script>
<script type="text/javascript" async="async" data-cfasync="false" src="https://ads.blogherads.com/sk/12/122/1223898/25759/header.js"></script>

<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>

<script type="text/javascript">
if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('bVenCmai4r37sZadbiUt4I');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='http://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}
</script>


<meta property="og:type" content="article" />
<meta property="og:title" content="#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)" />
<meta property="og:url" content="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/" />
<meta property="og:description" content="The Real Housewives of Atlanta may have a real life story to add to it&#8217;s latest season. Porsha Williams&#8217; baby daddy Dennis McKinley recently had a run in with an officer at Emory Univer…" />
<meta property="article:published_time" content="2019-07-29T17:29:34+00:00" />
<meta property="article:modified_time" content="2019-07-29T17:36:01+00:00" />
<meta property="og:site_name" content="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News" />
<meta property="og:image" content="http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2.jpg" />
<meta property="og:image:width" content="914" />
<meta property="og:image:height" content="768" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ATLien" />
<meta name="twitter:site" content="@ATLien" />
<meta name="twitter:text:title" content="#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)" />
<meta name="twitter:image" content="http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<style type="text/css" id="wp-custom-css">
				a.sociallink {color:#fff;} a.sociallink:hover {color:#fc0;}
.followme {color:#fc0;font-weight:bold; padding:0 .5em 0 0;}

.bottomleft-wrapper, .bottommid-wrapper, .bottomright-wrapper {margin:0 .1em;width:33%;}
.bottomleft-wrapper, .bottommid-wrapper {float:left;} .bottomright-wrapper {float:right;}
#bottoms {background-color:#000;border:5px solid #fff;color:#fff;margin:0 auto;padding:1em;width:980px;}
#bottoms h5 {text-align:center;}
#bottoms ul.bottom-posts li.bottom-post h4, #bottoms ul.bottom-posts li.bottom-post h4 a {color:#fff;display:block;font-size:11pt;padding:0;text-align:left;}
#bottoms ul.bottom-posts li.bottom-post {padding:0 1em;margin:0;background-color:#000;overflow:hidden;max-height:70px;}
#bottoms ul.bottom-posts li.bottom-post h4 a:hover {color:#f90;text-shadow:1px 1px 1px #000;}

.shareaholic-canvas {float:left;} .storycontent .shareaholic-canvas {float:none !important;}			</style>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Banner_Homepage', [728, 90], 'div-gpt-ad-1547679945509-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Header_Banner_728x90', [728, 90], 'div-gpt-ad-1547680417993-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_HeaderCube_Homepage', [300, 250], 'div-gpt-ad-1547680701469-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Header_Cube_300x250', [300, 250], 'div-gpt-ad-1547680977449-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_CUBE_TopRight_Homepage', [300, 250], 'div-gpt-ad-1547681450628-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
	
	  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA-SkyScraper-HP-NEW1', [160, 600], 'div-gpt-ad-1547681226438-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_CUBE_TOP_Right_300x250', [300, 250], 'div-gpt-ad-1547681797725-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Cube_BelowThePost', [300, 250], 'div-gpt-ad-1547681936467-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_CUBE_Below5thPost_300x250', [300, 250], 'div-gpt-ad-1547682486925-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_CUBE_Below3rdPost_300x250', [300, 250], 'div-gpt-ad-1547682602487-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Skyscraper_Homepage2', [160, 600], 'div-gpt-ad-1547682835523-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_160x600_3_Homepage', [160, 600], 'div-gpt-ad-1547683022227-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Sidebar_Middle_160x600', [160, 600], 'div-gpt-ad-1547683194967-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_RightSidebar_ROS1', [160, 600], 'div-gpt-ad-1547683418990-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_Sidebar_3_160x600', [160, 600], 'div-gpt-ad-1547683492034-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

  googletag.cmd.push(function() {
    googletag.defineSlot('/1093538/SFTA_FooterAd_728x90', [728, 90], 'div-gpt-ad-1547683739173-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  window.astip_client = "ca-tipjar-pub-8098644933888050"
</script>
<script async src="https://www.gstatic.com/astip/astip.js">
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID: 'b846b040-df14-49bd-b605-3dbd86535d3b', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
         slotID: 'div-gpt-ad-1538073634678-0'
         slotName: '/1093538/SFTA_HeaderCube_Homepage'
         sizes: [[300, 250]]
     },
     {
         slotID: 'div-gpt-ad-1538073788132-0'
         slotName: '/1093538/SFTA_Banner_Homepage'
         sizes: [[728,90]]
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
         googletag.pubads().refresh();
     });
}); 
</script>
<script src='https://use.fontawesome.com/804c885ca3.js'></script>
</head>
<body class="post-template-default single single-post postid-239590 single-format-standard">
<noscript><img src='//by217.com/eycjej?MXweWwIIFkhQRktHSlVWVxADE0MwB28UThdbTU4SV1hfWUEPEw8EElhHSlVAXFYbCUEEQVlaThdbT1YORx9HQ0NbUBc'/></noscript>
<div id="container">
<div class="top-wrapper"><div class="top"></div></div>
<header class="site-header">
<h1 class="title"><a href="http://straightfromthea.com/" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" class="identity"><img class="logo" src="http://straightfromthea.com/wp-content/uploads/2015/04/sftalogo31.png" alt="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" /></a></h1>
<div class="searcharea-wrapper">
<form action="https://www.google.com/cse" class="cse-search-box" id="cse-search-box" target="_blank"><input type="hidden" name="cx" value="partner-pub-8098644933888050:4muutu6gym3" /><input type="hidden" name="ie" value="UTF-8" /><input type="text" name="q" size="31" class="txt" /><input type="submit" name="sa" class="btn submit" value="Search" /></form><script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
<div class="socialbuttons-wrapper">
<span class="followme">Get Social: </span>
<a class="sociallink" href="http://straightfromthea.com/feed/" title="Straight From The A Feed">
<i class="fa fa-rss fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://twitter.com/atlien" title="Michelle 'ATLien' Brown On Twitter">
<i class="fa fa-twitter fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://instagram.com/iamatlien" title="ATLien on Instagram">
<i class="fa fa-instagram fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.youtube.com/c/atlien?sub_confrimation=1" title="ATLien on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
<a class="socilalink" href="https://www.youtube.com/michellebrown?sub_confrimation=1" title="Michelle 'ATLien' Brown on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://facebook.com/StraightFromTheA" title="Straight From The A on Facebook">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.facebook.com/groups/205126650085285/" title="A-SQUAD #TeamMichelle Facebook Group">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="http://iamatlien.com" title="ATLien on Tumblr">
<i class="fa fa-tumblr fa-lg" aria-hidden="true"></i>
</a>
</div>
</div>
</header>
<script type="text/javascript" src="http://ads.ayads.co/ajs.php?zid=17562"></script>
<center>
<div id='div-gpt-ad-1547680417993-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547680417993-0'); });
</script>
</div>
</center>
<nav class="top-navigation-wrapper"><div class="primary-navigation-menu"><ul id="menu-primary" class="menu"><li id="menu-item-176006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-176006"><a title="Home" href="http://straightfromthea.com/">Home</a></li>
<li id="menu-item-198946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-198946"><a href="http://straightfromthea.com/gallery">Photos</a></li>
<li id="menu-item-176009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176009"><a title="Archives" href="http://straightfromthea.com/archives/">Archives</a></li>
<li id="menu-item-176008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176008"><a title="Advertise" href="http://straightfromthea.com/advertise/">Advertise</a></li>
<li id="menu-item-176012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176012"><a title="About" href="http://straightfromthea.com/about/">About</a></li>
<li id="menu-item-176011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176011"><a title="Contact" href="http://straightfromthea.com/contact/">Contact</a></li>
<li id="menu-item-176007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176007"><a title="DMCA" href="http://straightfromthea.com/dmca/">DMCA</a></li>
<li id="menu-item-230886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230886"><a href="https://teespring.com/stores/atlien">Shop</a></li>
</ul></div></nav>
<br />
<div class="featured-wrapper">
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/" rel="bookmark" title="OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2019/07/engaged3-190x190.jpg" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2019/07/engaged3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2019/07/engaged3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2019/07/engaged3-144x144.jpg 144w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2019/07/engaged8-520x547.jpg" alt="OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/" rel="bookmark" title="OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)">OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2019/07/26/nelly-t-i-hold-intervention-for-bow-wow-after-derogatory-ciara-comment-video/" rel="bookmark" title="Nelly, T.I. Hold &#8220;INTERVENTION&#8221; For Bow Wow After Derogatory Ciara Comment&#8230; (VIDEO)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-300x300.png 300w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-520x521.png 520w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-640x641.png 640w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow-144x144.png 144w, http://straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow.png 767w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2019/07/T.I.-Bow-Wow-520x525.png" alt="Nelly, T.I. Hold &#8220;INTERVENTION&#8221; For Bow Wow After Derogatory Ciara Comment&#8230; (VIDEO)" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2019/07/26/nelly-t-i-hold-intervention-for-bow-wow-after-derogatory-ciara-comment-video/" rel="bookmark" title="Nelly, T.I. Hold &#8220;INTERVENTION&#8221; For Bow Wow After Derogatory Ciara Comment&#8230; (VIDEO)">Nelly, T.I. Hold &#8220;INTERVENTION&#8221; For Bow Wow After Derogatory Ciara Comment&#8230; (VIDEO)</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2019/07/26/why-do-men-cheat-nene-gregg-leakes-host-pillow-talk-discussion-video/" rel="bookmark" title="Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-300x299.png 300w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-768x765.png 768w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-520x518.png 520w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-640x638.png 640w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-144x144.png 144w, http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019.png 771w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2019/07/Nene-Gregg-leakes-2019-520x518.png" alt="Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO)" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2019/07/26/why-do-men-cheat-nene-gregg-leakes-host-pillow-talk-discussion-video/" rel="bookmark" title="Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO)">Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO)</a></h4>
</div>
<div class="featuredad">
<br>
<center>
<div id='div-gpt-ad-1547680977449-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547680977449-0'); });
</script>
</div></center>
</div>
<div class="clear"></div>
</div><ul id="main">
<li id="content">
<div class="post-239590 post type-post status-publish format-standard has-post-thumbnail hentry category-atlanta-gossip category-news tag-dennis-mckinley tag-for-discussion tag-open-post tag-porsha-williams tag-racial-profiling tag-wtf" id="post-239590">
<div class='shareaholic-canvas' data-app='share_buttons' data-title='#RHOA Porsha Williams&#039; Baby Daddy Racially Profiled By Police... (PHOTOS + VIDEO)' data-link='http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/' data-app-id='14600962'></div> <h1 class="storytitle">
<a href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/" rel="bookmark">#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)</a>
</h1>
<div class="meta">
Jul, 29 2019 | Written by ATLien </div>
<div class="storycontent">
<p><center><a href="http://straightfromthea.com/2019/05/31/rumor-control-rhoa-porsha-williams-baby-daddy-dennis-mckinley-denies-break-up-rumors/porsha-dennis-2-2/" rel="attachment wp-att-238539"><img src="http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-520x437.jpg" alt="" width="520" height="437" class="alignnone size-large wp-image-238539" srcset="http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-520x437.jpg 520w, http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-300x252.jpg 300w, http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-768x645.jpg 768w, http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2-640x538.jpg 640w, http://straightfromthea.com/wp-content/uploads/2019/05/Porsha-Dennis-2.jpg 914w" sizes="(max-width: 520px) 100vw, 520px" /></a></center></p>
<p>The Real Housewives of Atlanta may have a real life story to add to it&#8217;s latest season. </p>
<p>Porsha Williams&#8217; baby daddy Dennis McKinley recently had a run in with an officer at Emory University that he feels went a bit too far. McKinley post a clip of the incident to social media stating:</p>
<blockquote><p>Yesterday I was accosted by a super aggressive Emory police officer #BethWalsh badge #215 who racially profiled me and falsely accused me of stealing a $4 sandwich. </p></blockquote>
<p>Now he is threatening to sue the hospital after the devastating incident.</p>
<p>Details + video below&#8230;<span id="more-239590"></span></p>
<p>Dennis shared the story via Instagram, stating that he was at Emory University for a routine doctor&#8217;s appointment the he was accosted by officer Beth Walsh. Apparently Walsh accused the reality star of stealing a sandwich from the cafeteria and he was handcuffed, questioned and forced to prove his purchase.</p>
<p>Once he shared a receipt the officer let him go, but McKinley feels he was already publicly humiliated by the aggressive officer, who he says used too much force. He also shared photos of his bruised wrists and wrote a detailed post regarding the incident. </p>
<p><center></p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B0bo_2RFn4L/" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B0bo_2RFn4L/" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank" rel="noopener noreferrer"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B0bo_2RFn4L/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" rel="noopener noreferrer">Yesterday I was accosted by a super aggressive Emory police officer #BethWalsh badge #215 who racially profiled me and falsely accused me of stealing a $4 sandwich. I had a receipt which could have easily ended her inquiry. There was a cashier that could have easily verified that I paid for everything I had. There were a number of easy resolutions that could have deescalated the unnecessary racial profiling and my detention by this officer. Instead, this Emory police officer chose to abuse her power. She chose aggression over common sense. She put her hands on her weapon, she put her hands on me, she publicly humiliated me, falsely and wrongfully accused me of stealing a sandwich and placed me in handcuffs so tight that she caused injuries to both of my wrists. I was profiled. She was wrong. No apology. Just more vitriol &#8211; she blamed me for the entire situation. It was disgusting. I could have been the next hashtag because she was that aggressive. I went to see my doctor for a routine dr visit at @emoryhealthcare Emory hospital. Stopped to grab a sandwich. And this is what happened. It happens to us everywhere, at any time, for any reason. I can’t let this go. This is not ok. I’ve retained counsel @miketsterling and @dreyer_sterling_llc. Now, we can add going to the doctor or buying a sandwhich while black to the list of things we cannot do. @emoryuniversity @emoryhealthcare @emorypolice #goingtothedoctorwhileblack #buyingasandwhichwhileblack #racialprofiling #sallysandwich</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/workwincelebrate/" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank" rel="noopener noreferrer"> Dennis McKinley</a> (@workwincelebrate) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-07-27T19:26:29+00:00">Jul 27, 2019 at 12:26pm PDT</time></p>
</div>
</blockquote>
<p> <script async src="//www.instagram.com/embed.js"></script></center></p>
<p>Dennis also issued a statement after news outlets claimed it was merely an honest mistake:</p>
<p><center></p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B0eB6K7FcoM/" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/B0eB6K7FcoM/" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank" rel="noopener noreferrer"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B0eB6K7FcoM/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" rel="noopener noreferrer">WOW THIS IS WHAT EMORY @emorypolice TOLD @usweekly &#8230;that it? @miketsterling responds I’m at a loss for words ??“Emory’s response is clearly the response of privilege. The privilege of someone completely out of touch with the reality of what that harrowing experience was like for Dennis. It is a response that does not recognize the pain and anguish of being profiled, despite your personal accomplishments and standing in society; they don’t understand what it’s like to be viewed as a criminal for no reason at all, except how you look; they don’t understand what it’s like to be falsely accused of something you did not do; publicly humiliated for no reason at all; handcuffed like a criminal; detained without provocation; and completely frightened to death that you could be shot by an overly aggressive police officer over a $4 sandwich. Are you kidding me Emory. This type of indifference by Emory just made the experience all the more painful. This is shameful.“ #goingtothedoctorwhileblack #Emory</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/workwincelebrate/" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank" rel="noopener noreferrer"> Dennis McKinley</a> (@workwincelebrate) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-07-28T17:42:38+00:00">Jul 28, 2019 at 10:42am PDT</time></p>
</div>
</blockquote>
<p> <script async src="//www.instagram.com/embed.js"></script></center></p>
<p><center></p>
<h2>What are your thoughts about Dennis McKinley&#8217;s unfortunate brush with the law?</center></h2>
<div class="zem_rp_wrap zem_rp_th_vertical_m" id="zem_rp_first"><div class="zem_rp_content"><h3 class="related_post_title">Related Posts</h3><ul class="related_post zem_rp"><li data-position="0" data-poid="in-225625" data-post-type="none"><a href="http://straightfromthea.com/2018/03/25/open-post-should-a-woman-ever-propose-to-a-man-hear-what-men-say-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/03/woman-proposes-2-150x150.png" alt="OPEN POST:  Should A Woman Ever Propose To A Man? Hear What Men Say&#8230; (VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/03/25/open-post-should-a-woman-ever-propose-to-a-man-hear-what-men-say-video/" class="zem_rp_title">OPEN POST: Should A Woman Ever Propose To A Man? Hear What Men Say&#8230; (VIDEO)</a></li><li data-position="1" data-poid="in-230325" data-post-type="none"><a href="http://straightfromthea.com/2018/08/28/open-post-cardi-b-portrays-coretta-scott-in-real-housewives-spoof-are-we-mad-or-nah-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/08/Cardi-B-Coretta-Scott-King--150x150.jpg" alt="OPEN POST: Cardi B Portrays Coretta Scott in &#8216;Real Housewives&#8217; Spoof&#8230;. Are We Mad? Or Nah? (VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/08/28/open-post-cardi-b-portrays-coretta-scott-in-real-housewives-spoof-are-we-mad-or-nah-video/" class="zem_rp_title">OPEN POST: Cardi B Portrays Coretta Scott in &#8216;Real Housewives&#8217; Spoof&#8230;. Are We Mad? Or Nah? (VIDEO)</a></li><li data-position="2" data-poid="in-229641" data-post-type="none"><a href="http://straightfromthea.com/2018/08/06/wtf-racist-pig-goes-viral-with-story-of-contaminating-food-of-black-patrons-restaurant-issues-statement/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/08/wtf2-150x150.jpg" alt="WTF?!? Racist Pig Goes Viral With Story of Contaminating Food of Black Patrons, Restaurant Issues Statement&#8230;" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/08/06/wtf-racist-pig-goes-viral-with-story-of-contaminating-food-of-black-patrons-restaurant-issues-statement/" class="zem_rp_title">WTF?!? Racist Pig Goes Viral With Story of Contaminating Food of Black Patrons, Restaurant Issues Statement&#8230;</a></li><li data-position="3" data-poid="in-229799" data-post-type="none"><a href="http://straightfromthea.com/2018/08/13/another-atlanta-restaurant-solis-overdrive-lounge-accused-of-discriminatory-behavior/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/08/Screen-Shot-2018-08-13-at-10.04.56-AM-150x150.png" alt="Another Atlanta Restaurant (Solis Overdrive Lounge) Accused of Discriminatory Behavior&#8230;" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/08/13/another-atlanta-restaurant-solis-overdrive-lounge-accused-of-discriminatory-behavior/" class="zem_rp_title">Another Atlanta Restaurant (Solis Overdrive Lounge) Accused of Discriminatory Behavior&#8230;</a></li><li data-position="4" data-poid="in-229744" data-post-type="none"><a href="http://straightfromthea.com/2018/08/09/wtf-bait-truck-filled-with-nike-sneakers-allegedly-used-to-entrap-chicago-teens-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/08/turning-truck-150x150.png" alt="WTF?!? &#8216;Bait Truck&#8217; Filled With Nike Sneakers Allegedly Used To Entrap Chicago Teens&#8230; (VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/08/09/wtf-bait-truck-filled-with-nike-sneakers-allegedly-used-to-entrap-chicago-teens-video/" class="zem_rp_title">WTF?!? &#8216;Bait Truck&#8217; Filled With Nike Sneakers Allegedly Used To Entrap Chicago Teens&#8230; (VIDEO)</a></li></ul></div></div>
<div class='shareaholic-canvas' data-app='share_buttons' data-title='#RHOA Porsha Williams&#039; Baby Daddy Racially Profiled By Police... (PHOTOS + VIDEO)' data-link='http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/' data-app-id='14600957' data-app-id-name='post_below_content'></div>
<div class="pagination-wrapper">
</div>
</div>
<div style="font-size:10px;"><em> In <a href="http://straightfromthea.com/category/atlanta-gossip/" rel="category tag">Atlanta Gossip</a>,<a href="http://straightfromthea.com/category/news/" rel="category tag">News</a> <a href="http://straightfromthea.com/tag/dennis-mckinley/" rel="tag">Dennis McKinley</a>, <a href="http://straightfromthea.com/tag/for-discussion/" rel="tag">For Discussion</a>, <a href="http://straightfromthea.com/tag/open-post/" rel="tag">OPEN POST</a>, <a href="http://straightfromthea.com/tag/porsha-williams/" rel="tag">Porsha Williams</a>, <a href="http://straightfromthea.com/tag/racial-profiling/" rel="tag">Racial Profiling</a>, <a href="http://straightfromthea.com/tag/wtf/" rel="tag">WTF</a></em></div>
<div id="rcjsload_939d4c"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "http://trends.revcontent.com/serve.js.php?w=79590&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_939d4c"); rcds.appendChild(rcel);
})();
</script>
<div class="feedback">
</div>
</div>

<div class="comments" id="comments">
<div id="disqus_thread"></div>
</div>
<div class="navigation">
<div class="alignleft"></div>
<div class="alignright"></div>
</div>
</li>
<li id="sidebar">
<ul>
<center>
<div id='div-gpt-ad-1547681797725-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547681797725-0'); });
</script>
</div></center>
<li id="adspot">
<ul class="sidebar">
<div id="text-459501738" class="widget widget_text"> <div class="textwidget"><p><script data-config="//config.playwire.com/1003736/playlists/v2/4443/zeus.json" src="//cdn.playwire.com/bolt/js/zeus/embed.js"></script></p>
</div>
</div><div id="text-459501718" class="widget widget_text"><h4>Subscribe</h4> <div class="textwidget"><center><form class="feedburner-wrapper" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=sfta', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter email address to receive StraightFromTheA.com updates in your inbox:</p>
<p>Enter your email address:</p>
<p><input class="txt type=" text" name="email" />
<input type="hidden" value="sfta" name="uri" />
<input type="hidden" name="loc" value="en_US" />
<input class="btn" type="submit" value="Subscribe" />
</form></p></center></div>
</div></ul>
</li>
<li id="left">
<ul class="sidebar">
<div id="top-posts-6" class="widget widget_top-posts"><ul class='widgets-list-layout no-grav'>
<li>
<a href="http://straightfromthea.com/2019/07/26/nelly-t-i-hold-intervention-for-bow-wow-after-derogatory-ciara-comment-video/" title="Nelly, T.I. Hold &quot;INTERVENTION&quot; For Bow Wow After Derogatory Ciara Comment... (VIDEO)" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2019/07/Bow-Wow.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Nelly, T.I. Hold &quot;INTERVENTION&quot; For Bow Wow After Derogatory Ciara Comment... (VIDEO)" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2019/07/26/nelly-t-i-hold-intervention-for-bow-wow-after-derogatory-ciara-comment-video/" class="bump-view" data-bump-view="tp">
Nelly, T.I. Hold &quot;INTERVENTION&quot; For Bow Wow After Derogatory Ciara Comment... (VIDEO) </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/" title="OFF THE MARKET: #RHOA Cynthia Bailey &amp; Sportscaster Mike Hill Are Engaged... (PHOTOS)" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2019/07/engaged3.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="OFF THE MARKET: #RHOA Cynthia Bailey &amp; Sportscaster Mike Hill Are Engaged... (PHOTOS)" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/" class="bump-view" data-bump-view="tp">
OFF THE MARKET: #RHOA Cynthia Bailey &amp; Sportscaster Mike Hill Are Engaged... (PHOTOS) </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2019/07/26/exclusive-sneak-peek-growing-up-hip-hop-expands-to-new-york-w-ja-rule-flavor-flav-irv-gotti-more-video-guhh-guhhny/" title="EXCLUSIVE SNEAK PEEK: Growing Up Hip-Hop Expands to New York w/Ja Rule, Flavor Flav, Irv Gotti &amp; More... (VIDEO) #GUHH #GUHHNY" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/straightfromthea.com/wp-content/uploads/2019/07/Growing_Up_Hip_Hop_NY_cast_rev_2.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="EXCLUSIVE SNEAK PEEK: Growing Up Hip-Hop Expands to New York w/Ja Rule, Flavor Flav, Irv Gotti &amp; More... (VIDEO) #GUHH #GUHHNY" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2019/07/26/exclusive-sneak-peek-growing-up-hip-hop-expands-to-new-york-w-ja-rule-flavor-flav-irv-gotti-more-video-guhh-guhhny/" class="bump-view" data-bump-view="tp">
EXCLUSIVE SNEAK PEEK: Growing Up Hip-Hop Expands to New York w/Ja Rule, Flavor Flav, Irv Gotti &amp; More... (VIDEO) #GUHH #GUHHNY </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/" title="Facebook Fail! Young Mom Calls Her Own Baby &quot;Ugly &amp; Funny Looking&quot;... (VIDEO)" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2019/07/FACEBOOK-FAIL-UGLY-BABY-2019.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Facebook Fail! Young Mom Calls Her Own Baby &quot;Ugly &amp; Funny Looking&quot;... (VIDEO)" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/" class="bump-view" data-bump-view="tp">
Facebook Fail! Young Mom Calls Her Own Baby &quot;Ugly &amp; Funny Looking&quot;... (VIDEO) </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/" title="Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)..." class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2019/07/Lela-Rachon-Antoine-Fuqua-Nicole-Murphy.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)..." data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/" class="bump-view" data-bump-view="tp">
Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)... </a>
</div>
</li>
</ul>
</div><div id="archives-2" class="widget widget_archive"><h4>Archives</h4> <label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='http://straightfromthea.com/2019/07/'> July 2019 &nbsp;(49)</option>
<option value='http://straightfromthea.com/2019/06/'> June 2019 &nbsp;(33)</option>
<option value='http://straightfromthea.com/2019/05/'> May 2019 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2019/04/'> April 2019 &nbsp;(36)</option>
<option value='http://straightfromthea.com/2019/03/'> March 2019 &nbsp;(41)</option>
<option value='http://straightfromthea.com/2019/02/'> February 2019 &nbsp;(70)</option>
<option value='http://straightfromthea.com/2019/01/'> January 2019 &nbsp;(58)</option>
<option value='http://straightfromthea.com/2018/12/'> December 2018 &nbsp;(32)</option>
<option value='http://straightfromthea.com/2018/11/'> November 2018 &nbsp;(51)</option>
<option value='http://straightfromthea.com/2018/10/'> October 2018 &nbsp;(60)</option>
<option value='http://straightfromthea.com/2018/09/'> September 2018 &nbsp;(55)</option>
<option value='http://straightfromthea.com/2018/08/'> August 2018 &nbsp;(67)</option>
<option value='http://straightfromthea.com/2018/07/'> July 2018 &nbsp;(41)</option>
<option value='http://straightfromthea.com/2018/06/'> June 2018 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2018/05/'> May 2018 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2018/04/'> April 2018 &nbsp;(64)</option>
<option value='http://straightfromthea.com/2018/03/'> March 2018 &nbsp;(50)</option>
<option value='http://straightfromthea.com/2018/02/'> February 2018 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2018/01/'> January 2018 &nbsp;(105)</option>
<option value='http://straightfromthea.com/2017/12/'> December 2017 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2017/11/'> November 2017 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2017/10/'> October 2017 &nbsp;(88)</option>
<option value='http://straightfromthea.com/2017/09/'> September 2017 &nbsp;(77)</option>
<option value='http://straightfromthea.com/2017/08/'> August 2017 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2017/07/'> July 2017 &nbsp;(86)</option>
<option value='http://straightfromthea.com/2017/06/'> June 2017 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2017/05/'> May 2017 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2017/04/'> April 2017 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2017/03/'> March 2017 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2017/02/'> February 2017 &nbsp;(73)</option>
<option value='http://straightfromthea.com/2017/01/'> January 2017 &nbsp;(86)</option>
<option value='http://straightfromthea.com/2016/12/'> December 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/11/'> November 2016 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2016/10/'> October 2016 &nbsp;(70)</option>
<option value='http://straightfromthea.com/2016/09/'> September 2016 &nbsp;(61)</option>
<option value='http://straightfromthea.com/2016/08/'> August 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/07/'> July 2016 &nbsp;(55)</option>
<option value='http://straightfromthea.com/2016/06/'> June 2016 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2016/05/'> May 2016 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2016/04/'> April 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/03/'> March 2016 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2016/02/'> February 2016 &nbsp;(66)</option>
<option value='http://straightfromthea.com/2016/01/'> January 2016 &nbsp;(66)</option>
<option value='http://straightfromthea.com/2015/12/'> December 2015 &nbsp;(53)</option>
<option value='http://straightfromthea.com/2015/11/'> November 2015 &nbsp;(67)</option>
<option value='http://straightfromthea.com/2015/10/'> October 2015 &nbsp;(73)</option>
<option value='http://straightfromthea.com/2015/09/'> September 2015 &nbsp;(76)</option>
<option value='http://straightfromthea.com/2015/08/'> August 2015 &nbsp;(58)</option>
<option value='http://straightfromthea.com/2015/07/'> July 2015 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2015/06/'> June 2015 &nbsp;(83)</option>
<option value='http://straightfromthea.com/2015/05/'> May 2015 &nbsp;(70)</option>
<option value='http://straightfromthea.com/2015/04/'> April 2015 &nbsp;(74)</option>
<option value='http://straightfromthea.com/2015/03/'> March 2015 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2015/02/'> February 2015 &nbsp;(79)</option>
<option value='http://straightfromthea.com/2015/01/'> January 2015 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2014/12/'> December 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/11/'> November 2014 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2014/10/'> October 2014 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2014/09/'> September 2014 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2014/08/'> August 2014 &nbsp;(59)</option>
<option value='http://straightfromthea.com/2014/07/'> July 2014 &nbsp;(51)</option>
<option value='http://straightfromthea.com/2014/06/'> June 2014 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2014/05/'> May 2014 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2014/04/'> April 2014 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2014/03/'> March 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/02/'> February 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/01/'> January 2014 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2013/12/'> December 2013 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2013/11/'> November 2013 &nbsp;(78)</option>
<option value='http://straightfromthea.com/2013/10/'> October 2013 &nbsp;(103)</option>
<option value='http://straightfromthea.com/2013/09/'> September 2013 &nbsp;(90)</option>
<option value='http://straightfromthea.com/2013/08/'> August 2013 &nbsp;(95)</option>
<option value='http://straightfromthea.com/2013/07/'> July 2013 &nbsp;(76)</option>
<option value='http://straightfromthea.com/2013/06/'> June 2013 &nbsp;(88)</option>
<option value='http://straightfromthea.com/2013/05/'> May 2013 &nbsp;(79)</option>
<option value='http://straightfromthea.com/2013/04/'> April 2013 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2013/03/'> March 2013 &nbsp;(92)</option>
<option value='http://straightfromthea.com/2013/02/'> February 2013 &nbsp;(82)</option>
<option value='http://straightfromthea.com/2013/01/'> January 2013 &nbsp;(95)</option>
<option value='http://straightfromthea.com/2012/12/'> December 2012 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2012/11/'> November 2012 &nbsp;(81)</option>
<option value='http://straightfromthea.com/2012/10/'> October 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2012/09/'> September 2012 &nbsp;(85)</option>
<option value='http://straightfromthea.com/2012/08/'> August 2012 &nbsp;(104)</option>
<option value='http://straightfromthea.com/2012/07/'> July 2012 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2012/06/'> June 2012 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2012/05/'> May 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2012/04/'> April 2012 &nbsp;(122)</option>
<option value='http://straightfromthea.com/2012/03/'> March 2012 &nbsp;(120)</option>
<option value='http://straightfromthea.com/2012/02/'> February 2012 &nbsp;(134)</option>
<option value='http://straightfromthea.com/2012/01/'> January 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2011/12/'> December 2011 &nbsp;(102)</option>
<option value='http://straightfromthea.com/2011/11/'> November 2011 &nbsp;(110)</option>
<option value='http://straightfromthea.com/2011/10/'> October 2011 &nbsp;(127)</option>
<option value='http://straightfromthea.com/2011/09/'> September 2011 &nbsp;(132)</option>
<option value='http://straightfromthea.com/2011/08/'> August 2011 &nbsp;(123)</option>
<option value='http://straightfromthea.com/2011/07/'> July 2011 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2011/06/'> June 2011 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2011/05/'> May 2011 &nbsp;(112)</option>
<option value='http://straightfromthea.com/2011/04/'> April 2011 &nbsp;(114)</option>
<option value='http://straightfromthea.com/2011/03/'> March 2011 &nbsp;(130)</option>
<option value='http://straightfromthea.com/2011/02/'> February 2011 &nbsp;(134)</option>
<option value='http://straightfromthea.com/2011/01/'> January 2011 &nbsp;(141)</option>
<option value='http://straightfromthea.com/2010/12/'> December 2010 &nbsp;(135)</option>
<option value='http://straightfromthea.com/2010/11/'> November 2010 &nbsp;(141)</option>
<option value='http://straightfromthea.com/2010/10/'> October 2010 &nbsp;(154)</option>
<option value='http://straightfromthea.com/2010/09/'> September 2010 &nbsp;(122)</option>
<option value='http://straightfromthea.com/2010/08/'> August 2010 &nbsp;(109)</option>
<option value='http://straightfromthea.com/2010/07/'> July 2010 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2010/06/'> June 2010 &nbsp;(160)</option>
<option value='http://straightfromthea.com/2010/05/'> May 2010 &nbsp;(148)</option>
<option value='http://straightfromthea.com/2010/04/'> April 2010 &nbsp;(148)</option>
<option value='http://straightfromthea.com/2010/03/'> March 2010 &nbsp;(144)</option>
<option value='http://straightfromthea.com/2010/02/'> February 2010 &nbsp;(116)</option>
<option value='http://straightfromthea.com/2010/01/'> January 2010 &nbsp;(124)</option>
<option value='http://straightfromthea.com/2009/12/'> December 2009 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2009/11/'> November 2009 &nbsp;(82)</option>
<option value='http://straightfromthea.com/2009/10/'> October 2009 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2009/09/'> September 2009 &nbsp;(96)</option>
<option value='http://straightfromthea.com/2009/08/'> August 2009 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2009/07/'> July 2009 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2009/06/'> June 2009 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2009/05/'> May 2009 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2009/04/'> April 2009 &nbsp;(128)</option>
<option value='http://straightfromthea.com/2009/03/'> March 2009 &nbsp;(119)</option>
<option value='http://straightfromthea.com/2009/02/'> February 2009 &nbsp;(105)</option>
<option value='http://straightfromthea.com/2009/01/'> January 2009 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2008/12/'> December 2008 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2008/11/'> November 2008 &nbsp;(111)</option>
<option value='http://straightfromthea.com/2008/10/'> October 2008 &nbsp;(137)</option>
<option value='http://straightfromthea.com/2008/09/'> September 2008 &nbsp;(132)</option>
<option value='http://straightfromthea.com/2008/08/'> August 2008 &nbsp;(153)</option>
<option value='http://straightfromthea.com/2008/07/'> July 2008 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2008/06/'> June 2008 &nbsp;(111)</option>
<option value='http://straightfromthea.com/2008/05/'> May 2008 &nbsp;(123)</option>
<option value='http://straightfromthea.com/2008/04/'> April 2008 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2008/03/'> March 2008 &nbsp;(143)</option>
<option value='http://straightfromthea.com/2008/02/'> February 2008 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2008/01/'> January 2008 &nbsp;(60)</option>
<option value='http://straightfromthea.com/2007/12/'> December 2007 &nbsp;(29)</option>
<option value='http://straightfromthea.com/2007/11/'> November 2007 &nbsp;(26)</option>
<option value='http://straightfromthea.com/2007/10/'> October 2007 &nbsp;(25)</option>
<option value='http://straightfromthea.com/2007/09/'> September 2007 &nbsp;(28)</option>
<option value='http://straightfromthea.com/2007/08/'> August 2007 &nbsp;(21)</option>
</select>
<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="recent-comments-4" class="widget widget_recent_comments"><h4>Who&#8217;s Talking?</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/#comment-5543243">#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/#comment-5543244">#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/#comment-5543246">Facebook Fail! Young Mom Calls Her Own Baby &#8220;Ugly &#038; Funny Looking&#8221;&#8230; (VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/#comment-5543247">Facebook Fail! Young Mom Calls Her Own Baby &#8220;Ugly &#038; Funny Looking&#8221;&#8230; (VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/#comment-5543251">Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/#comment-5543250">Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/26/why-do-men-cheat-nene-gregg-leakes-host-pillow-talk-discussion-video/#comment-5543248">Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/#comment-5543249">Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/#comment-5543245">OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/#comment-5543239">Facebook Fail! Young Mom Calls Her Own Baby &#8220;Ugly &#038; Funny Looking&#8221;&#8230; (VIDEO)</a></li></ul></div></ul>
</li>
<li id="right">
<ul class="sidebar">
<center>
<br>
<div id='div-gpt-ad-1547683418990-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547683418990-0'); });
</script>
</div>

<br>

<div id='div-gpt-ad-1547683194967-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547683194967-0'); });
</script>
</div>

<br>

<div id='div-gpt-ad-1547683492034-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547683492034-0'); });
</script>
</div>

</center>
</ul>
</li>
<li class="clear">&nbsp;</li>
<li id="belowadspot">
<ul class="sidebar">
<div id="text-459501717" class="widget widget_text"><h4>Social Networks</h4> <div class="textwidget"><div style="display:block;margin:0 auto;text-align:center"><a title="ATLien's Tumblr (Personal Site)" href="http://iamATLien.com" target="_blank" rel="noopener noreferrer"><img title="iamATLien.com" alt="iamATLien.com" src="http://straightfromthea.com/wp-content/uploads/2012/06/fullscreen_capture_582011_123314_am.bmp-300x110.jpg" /></a></div>
</div>
</div><div id="text-459501741" class="widget widget_text"><h4>Patreon</h4> <div class="textwidget"><p><center><a href="https://www.patreon.com/iamatlien"><img class="size-medium wp-image-236685 aligncenter" src="http://straightfromthea.com/wp-content/uploads/2019/03/images-1-300x160.png" alt="" width="300" height="160" /></a></center><a href="https://www.patreon.com/iamatlien" target="_blank" rel="noopener noreferrer">Join me on Patreon</a> for weekly exclusives, blog tips and more.</p>
</div>
</div><div id="text-459501740" class="widget widget_text"><h4>YouTube</h4> <div class="textwidget"><p><center><iframe src="https://www.youtube.com/embed/videoseries?list=PLN6faKO2z1jcIEVxW9XJgYmOI-PqAq2Z0" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></center><br />
<br /><center><iframe src="https://www.youtube.com/embed/videoseries?list=PLN6faKO2z1jd2JahUtE3DhBKuejWDfMPI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></center></p>
<p class="text-center" style="text-align: center;"><strong>SUBSCRIBE</strong>:<a style="display: block; margin: 0 auto; text-align: center;" title="ATLien on YouTube" href="https://www.youtube.com/c/atlien?sub_confrimation=1"> ATLien on YouTube</a></p>
</div>
</div><div id="text-459501728" class="widget widget_text"><h4>Like Us on Facebook</h4> <div class="textwidget"><center><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FStraightFromTheA%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=527308440666890" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></center></div>
</div><div id="text-459501724" class="widget widget_text"><h4>Instagram</h4> <div class="textwidget"><div id="sb_instagram" class="sbi sbi_mob_col_auto sbi_fixed_height  sbi_col_4" style="width:340px; height:340px; background-color: #0a0400; padding-bottom: 4px; " data-id="3061145" data-num="8" data-res="auto" data-cols="4" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;showbio&quot;: &quot;false&quot;,&quot;feedID&quot;: &quot;3061145&quot;, &quot;headercolor&quot;: &quot;&quot;, &quot;imagepadding&quot;: &quot;2&quot;,&quot;mid&quot;: &quot;M2E4MWE5Zg==&quot;, &quot;disablecache&quot;: &quot;false&quot;, &quot;sbiCacheExists&quot;: &quot;true&quot;,&quot;callback&quot;: &quot;ZWMzZWI3ZWIzMDQ3NDQ.wOWIxNmI5YjliZGNmNDQzNzk=&quot;, &quot;sbiHeaderCache&quot;: &quot;true&quot;}'><div class="sb_instagram_header" style="padding: 4px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 2px;"><div class="sbi_loader"></div></div><div id="sbi_load" class="sbi_hidden"><a class="sbi_load_btn" href="javascript:void(0);" style="display: none; "><span class="sbi_btn_text">Load More...</span><span class="sbi_loader sbi_hidden"></span></a><span class="sbi_follow_btn"><a href="https://www.instagram.com/" style="" target="_blank" rel="noopener noreferrer"><i class="fa fab fa-instagram"></i>Follow on Instagram</a></span></div></div></div>
</div><div id="custom_html-3" class="widget_text widget widget_custom_html"><h4>ATLien for Dramatic Weight Loss</h4><div class="textwidget custom-html-widget"><center><iframe src="https://www.youtube.com/embed/videoseries?list=PLN6faKO2z1jcD2RvSFMzyBdSiDQtabcZD" width="300" height="260" frameborder="0" allowfullscreen=""></iframe></center>
<center>READ: <a href="http://straightfromthea.com/2011/09/20/atlien-dramatic-weight-loss-at-fso20/" target="_blank" rel="noopener noreferrer">My Ode to Dramatic Weight Loss (PHOTOS)</a></center>
<center>**StraightFromTheA.com readers receive special discount:</center>
<center><a href="http://straightfromthea.com/wp-content/uploads/2010/12/SFTA-DWL-coupon.pdf">CLICK HERE</a> for Discount Coupon!</center>
<center><script src="//ap.lijit.com/www/delivery/fpi.js?z=450117&width=300&height=250"></script> </center></div></div></ul>
</li>
</ul>
</li>
<li class="clear">&nbsp;</li>
</ul>
</div>
<div class="row" id="bottoms">
<div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 more-wrapper">
<div class="col-lg-4 col-md-4 bottomleft-wrapper">
<h5>Page 1</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/29/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video/" title="">
#RHOA Porsha Williams&#8217; Baby Daddy Racially Profiled By Police&#8230; (PHOTOS + VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/26/off-the-market-rhoa-cynthia-bailey-sportscaster-mike-hill-are-engaged-photos/" title="">
OFF THE MARKET: #RHOA Cynthia Bailey &#038; Sportscaster Mike Hill Are Engaged&#8230; (PHOTOS) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/26/nelly-t-i-hold-intervention-for-bow-wow-after-derogatory-ciara-comment-video/" title="">
Nelly, T.I. Hold &#8220;INTERVENTION&#8221; For Bow Wow After Derogatory Ciara Comment&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/26/facebook-fail-young-mom-calls-her-own-baby-ugly-funny-looking-video/" title="">
Facebook Fail! Young Mom Calls Her Own Baby &#8220;Ugly &#038; Funny Looking&#8221;&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/26/exclusive-sneak-peek-growing-up-hip-hop-expands-to-new-york-w-ja-rule-flavor-flav-irv-gotti-more-video-guhh-guhhny/" title="">
EXCLUSIVE SNEAK PEEK: Growing Up Hip-Hop Expands to New York w/Ja Rule, Flavor Flav, Irv Gotti &#038; More&#8230; (VIDEO) #GUHH #GUHHNY </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/26/why-do-men-cheat-nene-gregg-leakes-host-pillow-talk-discussion-video/" title="">
Why Do Men Cheat? #RHOA Nene &#038; Gregg Leakes Host Pillow Talk Discussion&#8230; (VIDEO) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="col-lg-4 col-md-4 bottommid-wrapper">
<h5>Page 2</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/25/quick-quotes-tiny-harris-responds-to-criticism-about-staying-with-t-i-despite-his-cheating-video/" title="">
Quick Quotes: Tiny Harris Responds To Criticism About Staying With T.I. Despite His Cheating&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/24/nicole-murphy-issues-public-apology-to-lela-rochon-after-being-caught-kissing-her-husband-antoine-fuqua/" title="">
Nicole Murphy Issues Public Apology To Lela Rochon After Being Caught Kissing Her Husband (Antoine Fuqua)&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/23/r-kellys-crisis-manager-quits-after-questionable-gayle-king-interview/" title="">
R. Kelly&#8217;s Crisis Manager QUITS After Questionable Gayle King Interview&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/23/open-post-bow-wow-upset-that-ciara-is-moved-on-without-him-rapper-brags-he-hit-it-first-video/" title="">
OPEN POST: Bow Wow Upset That Ciara is Moved On Without Him? Rapper Brags He &#8216;Hit It First&#8217;&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/22/caught-on-camera-futures-bodyguard-got-knocked-theee-fck-out-in-spain-video/" title="">
CAUGHT ON CAMERA: Future&#8217;s Bodyguard Got KNOCKED THEEE F*CK OUT in Spain&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/22/jermaine-dupri-hosts-screening-of-soso-def-documentary-usher-bow-wow-da-brat-more-attend-photos/" title="">
Jermaine Dupri Hosts VIP Screening of SoSo Def Documentary: Usher, Bow Wow, Da Brat &#038; More Attend&#8230; (PHOTOS) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="col-lg-4 col-md-4 bottomright-wrapper">
<h5>Page 3</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/22/r-kellys-crisis-manager-admits-hed-never-leave-his-daughter-with-kelly-video/" title="">
R. Kelly&#8217;s Crisis Manager Admits He&#8217;d Never Leave His Daughter With Kelly&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/19/wendy-williams-celebrates-55th-birthday-at-tiffanys-with-expensive-gifts-from-mystery-benefactor-photos-video/" title="">
Wendy Williams Celebrates 55th Birthday At Tiffany&#8217;s With Expensive Gifts From Mystery &#8216;Benefactor&#8217;&#8230; (PHOTOS + VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/19/exclusive-rhoa-season-12-tea-kenya-moore-kicked-out-of-marlo-hamptons-iamher-soft-launch-event-photos/" title="">
EXCLUSIVE #RHOA Season 12 Tea! Kenya Moore KICKED OUT Of Marlo Hampton&#8217;s #iAmHer Soft Launch Event&#8230; (PHOTOS) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/19/usher-still-fighting-to-keep-herpes-case-medical-records-sealed/" title="">
Usher Still Fighting To Keep Herpes Case Medical Records Sealed&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/17/morehouse-college-employee-on-indefinite-unpaid-leave-after-several-students-allege-inappropriate-sexual-conduct-video/" title="">
Morehouse College Employee on &#8216;Indefinite Unpaid Leave&#8217; After Several Students Allege Inappropriate Sexual Conduct&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2019/07/17/kandi-burruss-responds-to-phaedra-parks-shade-shes-canceled-video/" title="">
Kandi Burruss Responds to Phaedra Parks Shade: &#8216;She&#8217;s Canceled&#8230;&#8217; (VIDEO) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="clear"></div>
</div>
</div>
<div id="footer">
<br />
<center>


<div id='div-gpt-ad-1547683739173-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547683739173-0'); });
</script>
</div>

</center>
<center>
<a href="http://straightfromthea.com" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News" style="color:#fff;">&copy; 2007 - 2019 Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News</a><br />
<br />
<p class="credit" id="credit" itemprop="credit"><a class="credit-link" href="http://zillzdesignedit.com/" title="ZILLZDESIGNEDIT"><img src="http://straightfromthea.com/wp-content/uploads/2016/11/zillzdesignedit.png" alt="ZILLZDESIGNEDIT" width="70" height="45" class="alignnone size-full wp-image-204328" /></a></p>
<script id="_wau1b5">var _wau = _wau || []; _wau.push(["small", "47765hfex33c", "1b5"]);
(function() {var s=document.createElement("script"); s.async=true;
s.src="http://widgets.amung.us/small.js";
document.getElementsByTagName("head")[0].appendChild(s);
})();</script></center>
</div>

<script type="text/javascript">
var sbiajaxurl = "http://straightfromthea.com/wp-admin/admin-ajax.php";
</script>
 <div style="display:none">
</div>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"straightfromthea"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"239590 http:\/\/straightfromthea.com\/?p=239590","disqusShortname":"straightfromthea","disqusTitle":"#RHOA Porsha Williams\u2019 Baby Daddy Racially Profiled By Police\u2026 (PHOTOS + VIDEO)","disqusUrl":"http:\/\/straightfromthea.com\/2019\/07\/29\/rhoa-porsha-williams-baby-daddy-racially-profiled-by-police-video\/","postId":"239590"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.12.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201931'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201931.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'39327528',post:'239590',tz:'-4',srv:'straightfromthea.com'} ]);
	_stq.push([ 'clickTrackerInit', '39327528', '239590' ]);
</script>

<script type="text/javascript">
_qoptions={
qacct:"p-fbtLAmt-wiiPM"
};
</script>
<script type="text/javascript" src="https://www.quantserve.com/quant.js"></script>
<noscript>
<a href="http://www.quantcast.com/p-fbtLAmt-wiiPM" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-fbtLAmt-wiiPM.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></a>
</noscript>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5176916-1', 'auto');
  ga('send', 'pageview');

</script>
<script id="dsq-count-scr" src="//straightfromthea.disqus.com/count.js" async></script>
</body>
</html>