
<!DOCTYPE html>
<!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]--><!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]--><!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]--><!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]--><!--[if (gt IE 9)|!(IE)]><!-->
<html class="no-js" dir="ltr" xmlns="http://www.w3.org/1999/xhtml" xmlns:b="http://www.google.com/2005/gml/b" xmlns:c="http://s.opencalais.com/1/pred/" xmlns:ctag="http://commontag.org/ns#" xmlns:data="http://www.google.com/2005/gml/data" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:dcterm="http://purl.org/dc/terms/" xmlns:expr="http://www.google.com/2005/gml/expr" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioctypes="http://rdfs.org/sioc/types#" xmlns:v="http://rdf.data-vocabulary.org/#" xmlns:meebo="http://www.meebo.com" xmlns:addthis="http://www.addthis.com/help/api-spec" itemscope itemtype="http://schema.org/Blog" lang="en-US"><!--<![endif]-->
<head profile="http://gmpg.org/xfn/11">
<title>Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)
</title>
<meta name="robots" content="index,follow" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta content="Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" name="description" />
<meta name="y_key" content="a253b756d4a876c5" />
<meta name="dmoz.id" content="" />
<meta property="twitter:account_id" content="14174554" />
<meta name="revisit-after" content="1 days" />
<meta name="rating" content="General" />
<meta name="classification" content="Weblog" />
<meta name="distribution" content="global" />
<meta name="MSSmartTagsPreventParsing" content="true" />
<meta name="author" content="ATLien" />
<meta name="google-site-verification" content="Vd1bL8T_A-b8076YudJJ2IbndwiRwXElhAqh3dlV4H4" />
<meta name="google-site-verification" content="v14OaPeUZU9C5AnL4MrJqsci05Fupa8MC_jE4E-1nwg" />
<meta name="google-site-verification" content="jU20Mb9_9KmsJQdSe2GcYvVbMkRwps5eNNcu2aKO56A" />
<meta name="keywords" content="ATLANTA gossip,phaedra parks,NeNe Leakes,fantasia barrino,celebrity gossip,urban gossip,Big Boi,Outkast,andre 3000,Atlanta,Atlanta Housewives,the real housewives of atlanta,Beyonce,kandi burruss,Rhianna,Ne-Yo,ludacris,cynthia bailey,rumors,sheree whitfield,phaedra parks,hip-hop,goodie mob,love and hip hop atlanta,77UIfg_LokXvsryzwoLDjhWxNBE" />
<meta name="verify-v1" content="aX4NgU4kvosERqQla4iWMtzN7/HOKCDPc+3FKKrbVzc=" />
<meta name="google-site-verification" content="sLJCSXVOSaUoODbIg7m2cCQniGLDv0u-8nDyc6sGyOU" />
<script src="/cdn-cgi/apps/head/AtmWmoozrQ5epw_85tNGK6N6zTE.js"></script><link href="http://straightfromthea.com/wp-content/themes/sfta/style.css" type="text/css" rel="stylesheet" />
<link rel="shortcut icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.ico" />
<link rel="icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.gif" type="image/gif" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://straightfromthea.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="http://straightfromthea.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 1.0" href="http://straightfromthea.com/feed/atom/" />
<link rel="pingback" href="http://straightfromthea.com/xmlrpc.php" />
<link rel='archives' title='November 2018' href='http://straightfromthea.com/2018/11/' />
<link rel='archives' title='October 2018' href='http://straightfromthea.com/2018/10/' />
<link rel='archives' title='September 2018' href='http://straightfromthea.com/2018/09/' />
<link rel='archives' title='August 2018' href='http://straightfromthea.com/2018/08/' />
<link rel='archives' title='July 2018' href='http://straightfromthea.com/2018/07/' />
<link rel='archives' title='June 2018' href='http://straightfromthea.com/2018/06/' />
<link rel='archives' title='May 2018' href='http://straightfromthea.com/2018/05/' />
<link rel='archives' title='April 2018' href='http://straightfromthea.com/2018/04/' />
<link rel='archives' title='March 2018' href='http://straightfromthea.com/2018/03/' />
<link rel='archives' title='February 2018' href='http://straightfromthea.com/2018/02/' />
<link rel='archives' title='January 2018' href='http://straightfromthea.com/2018/01/' />
<link rel='archives' title='December 2017' href='http://straightfromthea.com/2017/12/' />
<link rel='archives' title='November 2017' href='http://straightfromthea.com/2017/11/' />
<link rel='archives' title='October 2017' href='http://straightfromthea.com/2017/10/' />
<link rel='archives' title='September 2017' href='http://straightfromthea.com/2017/09/' />
<link rel='archives' title='August 2017' href='http://straightfromthea.com/2017/08/' />
<link rel='archives' title='July 2017' href='http://straightfromthea.com/2017/07/' />
<link rel='archives' title='June 2017' href='http://straightfromthea.com/2017/06/' />
<link rel='archives' title='May 2017' href='http://straightfromthea.com/2017/05/' />
<link rel='archives' title='April 2017' href='http://straightfromthea.com/2017/04/' />
<link rel='archives' title='March 2017' href='http://straightfromthea.com/2017/03/' />
<link rel='archives' title='February 2017' href='http://straightfromthea.com/2017/02/' />
<link rel='archives' title='January 2017' href='http://straightfromthea.com/2017/01/' />
<link rel='archives' title='December 2016' href='http://straightfromthea.com/2016/12/' />
<link rel='archives' title='November 2016' href='http://straightfromthea.com/2016/11/' />
<link rel='archives' title='October 2016' href='http://straightfromthea.com/2016/10/' />
<link rel='archives' title='September 2016' href='http://straightfromthea.com/2016/09/' />
<link rel='archives' title='August 2016' href='http://straightfromthea.com/2016/08/' />
<link rel='archives' title='July 2016' href='http://straightfromthea.com/2016/07/' />
<link rel='archives' title='June 2016' href='http://straightfromthea.com/2016/06/' />
<link rel='archives' title='May 2016' href='http://straightfromthea.com/2016/05/' />
<link rel='archives' title='April 2016' href='http://straightfromthea.com/2016/04/' />
<link rel='archives' title='March 2016' href='http://straightfromthea.com/2016/03/' />
<link rel='archives' title='February 2016' href='http://straightfromthea.com/2016/02/' />
<link rel='archives' title='January 2016' href='http://straightfromthea.com/2016/01/' />
<link rel='archives' title='December 2015' href='http://straightfromthea.com/2015/12/' />
<link rel='archives' title='November 2015' href='http://straightfromthea.com/2015/11/' />
<link rel='archives' title='October 2015' href='http://straightfromthea.com/2015/10/' />
<link rel='archives' title='September 2015' href='http://straightfromthea.com/2015/09/' />
<link rel='archives' title='August 2015' href='http://straightfromthea.com/2015/08/' />
<link rel='archives' title='July 2015' href='http://straightfromthea.com/2015/07/' />
<link rel='archives' title='June 2015' href='http://straightfromthea.com/2015/06/' />
<link rel='archives' title='May 2015' href='http://straightfromthea.com/2015/05/' />
<link rel='archives' title='April 2015' href='http://straightfromthea.com/2015/04/' />
<link rel='archives' title='March 2015' href='http://straightfromthea.com/2015/03/' />
<link rel='archives' title='February 2015' href='http://straightfromthea.com/2015/02/' />
<link rel='archives' title='January 2015' href='http://straightfromthea.com/2015/01/' />
<link rel='archives' title='December 2014' href='http://straightfromthea.com/2014/12/' />
<link rel='archives' title='November 2014' href='http://straightfromthea.com/2014/11/' />
<link rel='archives' title='October 2014' href='http://straightfromthea.com/2014/10/' />
<link rel='archives' title='September 2014' href='http://straightfromthea.com/2014/09/' />
<link rel='archives' title='August 2014' href='http://straightfromthea.com/2014/08/' />
<link rel='archives' title='July 2014' href='http://straightfromthea.com/2014/07/' />
<link rel='archives' title='June 2014' href='http://straightfromthea.com/2014/06/' />
<link rel='archives' title='May 2014' href='http://straightfromthea.com/2014/05/' />
<link rel='archives' title='April 2014' href='http://straightfromthea.com/2014/04/' />
<link rel='archives' title='March 2014' href='http://straightfromthea.com/2014/03/' />
<link rel='archives' title='February 2014' href='http://straightfromthea.com/2014/02/' />
<link rel='archives' title='January 2014' href='http://straightfromthea.com/2014/01/' />
<link rel='archives' title='December 2013' href='http://straightfromthea.com/2013/12/' />
<link rel='archives' title='November 2013' href='http://straightfromthea.com/2013/11/' />
<link rel='archives' title='October 2013' href='http://straightfromthea.com/2013/10/' />
<link rel='archives' title='September 2013' href='http://straightfromthea.com/2013/09/' />
<link rel='archives' title='August 2013' href='http://straightfromthea.com/2013/08/' />
<link rel='archives' title='July 2013' href='http://straightfromthea.com/2013/07/' />
<link rel='archives' title='June 2013' href='http://straightfromthea.com/2013/06/' />
<link rel='archives' title='May 2013' href='http://straightfromthea.com/2013/05/' />
<link rel='archives' title='April 2013' href='http://straightfromthea.com/2013/04/' />
<link rel='archives' title='March 2013' href='http://straightfromthea.com/2013/03/' />
<link rel='archives' title='February 2013' href='http://straightfromthea.com/2013/02/' />
<link rel='archives' title='January 2013' href='http://straightfromthea.com/2013/01/' />
<link rel='archives' title='December 2012' href='http://straightfromthea.com/2012/12/' />
<link rel='archives' title='November 2012' href='http://straightfromthea.com/2012/11/' />
<link rel='archives' title='October 2012' href='http://straightfromthea.com/2012/10/' />
<link rel='archives' title='September 2012' href='http://straightfromthea.com/2012/09/' />
<link rel='archives' title='August 2012' href='http://straightfromthea.com/2012/08/' />
<link rel='archives' title='July 2012' href='http://straightfromthea.com/2012/07/' />
<link rel='archives' title='June 2012' href='http://straightfromthea.com/2012/06/' />
<link rel='archives' title='May 2012' href='http://straightfromthea.com/2012/05/' />
<link rel='archives' title='April 2012' href='http://straightfromthea.com/2012/04/' />
<link rel='archives' title='March 2012' href='http://straightfromthea.com/2012/03/' />
<link rel='archives' title='February 2012' href='http://straightfromthea.com/2012/02/' />
<link rel='archives' title='January 2012' href='http://straightfromthea.com/2012/01/' />
<link rel='archives' title='December 2011' href='http://straightfromthea.com/2011/12/' />
<link rel='archives' title='November 2011' href='http://straightfromthea.com/2011/11/' />
<link rel='archives' title='October 2011' href='http://straightfromthea.com/2011/10/' />
<link rel='archives' title='September 2011' href='http://straightfromthea.com/2011/09/' />
<link rel='archives' title='August 2011' href='http://straightfromthea.com/2011/08/' />
<link rel='archives' title='July 2011' href='http://straightfromthea.com/2011/07/' />
<link rel='archives' title='June 2011' href='http://straightfromthea.com/2011/06/' />
<link rel='archives' title='May 2011' href='http://straightfromthea.com/2011/05/' />
<link rel='archives' title='April 2011' href='http://straightfromthea.com/2011/04/' />
<link rel='archives' title='March 2011' href='http://straightfromthea.com/2011/03/' />
<link rel='archives' title='February 2011' href='http://straightfromthea.com/2011/02/' />
<link rel='archives' title='January 2011' href='http://straightfromthea.com/2011/01/' />
<link rel='archives' title='December 2010' href='http://straightfromthea.com/2010/12/' />
<link rel='archives' title='November 2010' href='http://straightfromthea.com/2010/11/' />
<link rel='archives' title='October 2010' href='http://straightfromthea.com/2010/10/' />
<link rel='archives' title='September 2010' href='http://straightfromthea.com/2010/09/' />
<link rel='archives' title='August 2010' href='http://straightfromthea.com/2010/08/' />
<link rel='archives' title='July 2010' href='http://straightfromthea.com/2010/07/' />
<link rel='archives' title='June 2010' href='http://straightfromthea.com/2010/06/' />
<link rel='archives' title='May 2010' href='http://straightfromthea.com/2010/05/' />
<link rel='archives' title='April 2010' href='http://straightfromthea.com/2010/04/' />
<link rel='archives' title='March 2010' href='http://straightfromthea.com/2010/03/' />
<link rel='archives' title='February 2010' href='http://straightfromthea.com/2010/02/' />
<link rel='archives' title='January 2010' href='http://straightfromthea.com/2010/01/' />
<link rel='archives' title='December 2009' href='http://straightfromthea.com/2009/12/' />
<link rel='archives' title='November 2009' href='http://straightfromthea.com/2009/11/' />
<link rel='archives' title='October 2009' href='http://straightfromthea.com/2009/10/' />
<link rel='archives' title='September 2009' href='http://straightfromthea.com/2009/09/' />
<link rel='archives' title='August 2009' href='http://straightfromthea.com/2009/08/' />
<link rel='archives' title='July 2009' href='http://straightfromthea.com/2009/07/' />
<link rel='archives' title='June 2009' href='http://straightfromthea.com/2009/06/' />
<link rel='archives' title='May 2009' href='http://straightfromthea.com/2009/05/' />
<link rel='archives' title='April 2009' href='http://straightfromthea.com/2009/04/' />
<link rel='archives' title='March 2009' href='http://straightfromthea.com/2009/03/' />
<link rel='archives' title='February 2009' href='http://straightfromthea.com/2009/02/' />
<link rel='archives' title='January 2009' href='http://straightfromthea.com/2009/01/' />
<link rel='archives' title='December 2008' href='http://straightfromthea.com/2008/12/' />
<link rel='archives' title='November 2008' href='http://straightfromthea.com/2008/11/' />
<link rel='archives' title='October 2008' href='http://straightfromthea.com/2008/10/' />
<link rel='archives' title='September 2008' href='http://straightfromthea.com/2008/09/' />
<link rel='archives' title='August 2008' href='http://straightfromthea.com/2008/08/' />
<link rel='archives' title='July 2008' href='http://straightfromthea.com/2008/07/' />
<link rel='archives' title='June 2008' href='http://straightfromthea.com/2008/06/' />
<link rel='archives' title='May 2008' href='http://straightfromthea.com/2008/05/' />
<link rel='archives' title='April 2008' href='http://straightfromthea.com/2008/04/' />
<link rel='archives' title='March 2008' href='http://straightfromthea.com/2008/03/' />
<link rel='archives' title='February 2008' href='http://straightfromthea.com/2008/02/' />
<link rel='archives' title='January 2008' href='http://straightfromthea.com/2008/01/' />
<link rel='archives' title='December 2007' href='http://straightfromthea.com/2007/12/' />
<link rel='archives' title='November 2007' href='http://straightfromthea.com/2007/11/' />
<link rel='archives' title='October 2007' href='http://straightfromthea.com/2007/10/' />
<link rel='archives' title='September 2007' href='http://straightfromthea.com/2007/09/' />
<link rel='archives' title='August 2007' href='http://straightfromthea.com/2007/08/' />
<title>Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//apps.shareaholic.com' />
<link rel='dns-prefetch' href='//grace.shareaholic.com' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Feed" href="http://straightfromthea.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Comments Feed" href="http://straightfromthea.com/comments/feed/" />
<meta name="description" content="Donald Glover surprised festival-goers attending his Pharos Festival in New Zealand this past weekend when he debuted the trailer for his mysterious upcoming..." />
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO) Comments Feed" href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/feed/" />
<meta name="keywords" content="Donald Glover, Rihanna" />
<meta name="robots" content="index,follow,noodp,noydir" />
<link rel="canonical" href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/" />

<link rel='preload' href='//apps.shareaholic.com/assets/pub/shareaholic.js' as='script'>
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/straightfromthea.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"http:\/\/straightfromthea.com\/wp-admin\/admin-ajax.php"},"url_components":{"year":"2018","monthnum":"11","day":"26","hour":"10","minute":"51","second":"37","post_id":"233592","postname":"sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video","author":"atlien","category":"news"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false' src='//apps.shareaholic.com/assets/pub/shareaholic.js' data-shr-siteid='6138b4eb6e460dce4355a17f4f16ad8e' async='async'>
</script>

<meta name='shareaholic:site_name' content='Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/' />
<meta name='shareaholic:keywords' content='donald glover, rihanna, atlanta gossip, news, post' />
<meta name='shareaholic:article_published_time' content='2018-11-26T10:51:37+00:00' />
<meta name='shareaholic:article_modified_time' content='2018-11-26T10:51:39+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='ATLien' />
<meta name='shareaholic:site_id' content='6138b4eb6e460dce4355a17f4f16ad8e' />
<meta name='shareaholic:wp_version' content='8.8.4' />
<meta name='shareaholic:image' content='http://straightfromthea.com/wp-content/uploads/2018/11/Donald-Glover-Rihanna-640x694.jpg' />

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/straightfromthea.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sb_instagram_styles-css' href='http://straightfromthea.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.10.1' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='http://straightfromthea.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://straightfromthea.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.7' type='text/css' media='all' />
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://straightfromthea.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://straightfromthea.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://straightfromthea.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;' href='http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/' />
<link rel='next' title='5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230;' href='http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p2F0SY-YLC' />
<link rel="alternate" type="application/json+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2018%2F11%2F26%2Fsneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2018%2F11%2F26%2Fsneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video%2F&#038;format=xml" />
<script type="text/javascript">
	window._zem_rp_post_id = '233592';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'Sneak+Peek%3A+Clip+of+Donald+Glover+%26+Rihanna%27s+Secret+Movie+Project+Leaks+Online...+%28VIDEO%29';
	window._zem_rp_post_tags = ['donald+glover', 'rihanna', 'atlanta+gossip', 'news', 'donald', 'film', 'movi', 'festiv', 'trailer', 'atlanta', 'video', 'tv', 'gambino', 'zealand', 'glover', 'rihanna', 'wright', 'cuba', 'music'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'http://straightfromthea.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '5';
</script>
<link rel="stylesheet" href="http://straightfromthea.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical-m.css?version=1.14" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>

<script type="text/javascript">
if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('bVenCmai4r37sZadbiUt4I');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='http://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}
</script>


<meta property="og:type" content="article" />
<meta property="og:title" content="Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)" />
<meta property="og:url" content="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/" />
<meta property="og:description" content="Donald Glover surprised festival-goers attending his Pharos Festival in New Zealand this past weekend when he debuted the trailer for his mysterious upcoming cinematic collaboration with Rihanna. T…" />
<meta property="article:published_time" content="2018-11-26T14:51:37+00:00" />
<meta property="article:modified_time" content="2018-11-26T14:51:39+00:00" />
<meta property="article:author" content="https://www.facebook.com/Michelle-Brown-256725178368110/" />
<meta property="og:site_name" content="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News" />
<meta property="og:image" content="http://straightfromthea.com/wp-content/uploads/2018/11/Donald-Glover-Rihanna.jpg" />
<meta property="og:image:width" content="708" />
<meta property="og:image:height" content="768" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@ATLien" />
<meta name="twitter:site" content="@ATLien" />
<meta name="twitter:text:title" content="Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)" />
<meta name="twitter:image" content="http://straightfromthea.com/wp-content/uploads/2018/11/Donald-Glover-Rihanna.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<script type='text/javascript' src="https://partner.googleadservices.com/gampad/google_service.js">
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-8098644933888050");
GS_googleEnableAllServices();
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Banner_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_HeaderCube_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_TopRight_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA-SkyScraper-HP-NEW1"); 
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Skyscraper_Homepage2");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_160x600_3_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Cube_RightSidebar_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_300x250_1"); 
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_Below3rdPost_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_Below5thPost_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_FooterAd_728x90");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Header_Banner_728x90");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Header_Cube_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_TOP_Right_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_RightSidebar_ROS1");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Sidebar_Middle_160x600");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Sidebar_3_160x600");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Cube_BelowThePost");
</script>
<script>
  window.astip_client = "ca-tipjar-pub-8098644933888050"
</script>
<script async src="https://www.gstatic.com/astip/astip.js">
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID: 'b846b040-df14-49bd-b605-3dbd86535d3b', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
         slotID: 'div-gpt-ad-1538073634678-0'
         slotName: '/1093538/SFTA_HeaderCube_Homepage'
         sizes: [[300, 250]]
     },
     {
         slotID: 'div-gpt-ad-1538073788132-0'
         slotName: '/1093538/SFTA_Banner_Homepage'
         sizes: [[728,90]]
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
         googletag.pubads().refresh();
     });
}); 
</script>
<style>a.sociallink {color:#fff;} a.sociallink:hover {color:#fc0;}
.followme {color:#fc0;font-weight:bold; padding:0 .5em 0 0;}

.bottomleft-wrapper, .bottommid-wrapper, .bottomright-wrapper {margin:0 .1em;width:33%;}
.bottomleft-wrapper, .bottommid-wrapper {float:left;} .bottomright-wrapper {float:right;}
#bottoms {background-color:#000;border:5px solid #fff;color:#fff;margin:0 auto;padding:1em;width:980px;}
#bottoms h5 {text-align:center;}
#bottoms ul.bottom-posts li.bottom-post h4, #bottoms ul.bottom-posts li.bottom-post h4 a {color:#fff;display:block;font-size:11pt;padding:0;text-align:left;}
#bottoms ul.bottom-posts li.bottom-post {padding:0 1em;margin:0;background-color:#000;overflow:hidden;max-height:70px;}
#bottoms ul.bottom-posts li.bottom-post h4 a:hover {color:#f90;text-shadow:1px 1px 1px #000;}
</style>
<script src='https://use.fontawesome.com/804c885ca3.js'></script>
</head>
<body class="post-template-default single single-post postid-233592 single-format-standard">
<div id="container">
<div class="top-wrapper"><div class="top"></div></div>
<header class="site-header">
<h1 class="title"><a href="http://straightfromthea.com/" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" class="identity"><img class="logo" src="http://straightfromthea.com/wp-content/uploads/2015/04/sftalogo31.png" alt="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" /></a></h1>
<div class="searcharea-wrapper">
<form action="https://www.google.com/cse" class="cse-search-box" id="cse-search-box" target="_blank"><input type="hidden" name="cx" value="partner-pub-8098644933888050:4muutu6gym3" /><input type="hidden" name="ie" value="UTF-8" /><input type="text" name="q" size="31" class="txt" /><input type="submit" name="sa" class="btn submit" value="Search" /></form><script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
<div class="socialbuttons-wrapper">
<span class="followme">Get Social: </span>
<a class="sociallink" href="http://straightfromthea.com/feed/" title="Straight From The A Feed">
<i class="fa fa-rss fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://twitter.com/atlien" title="Michelle 'ATLien' Brown On Twitter">
<i class="fa fa-twitter fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.facebook.com/MichelleDBrown" title="Michelle 'ATLien' Brown on Facebook">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://facebook.com/StraightFromTheA" title="Straight From The A on Facebook">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.facebook.com/groups/205126650085285/" title="A-SQUAD #TeamMichelle Facebook Group">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://instagram.com/iamatlien" title="ATLien on Instagram">
<i class="fa fa-instagram fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://snapchat.com/add/iamatlien" title="ATLien on Snapchat">
<i class="fa fa-snapchat fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://periscope.tv/atlien" title="ATLien on Periscope">
<i class="fa fa-circle fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="http://iamatlien.com" title="ATLien on Tumblr">
<i class="fa fa-tumblr fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.youtube.com/c/atlien?sub_confrimation=1" title="ATLien on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.youtube.com/channel/UCWhCD2KyhIm1cW8DMwUJAIA?sub_confrimation=1" title="Straight From The A on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
<a class="socilalink" href="https://www.youtube.com/michellebrown?sub_confrimation=1" title="Michelle 'ATLien' Brown on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
</div>
</div>
</header>
<script type="text/javascript" src="http://ads.ayads.co/ajs.php?zid=17562"></script>
<center>

<script type='text/javascript'>
GA_googleFillSlot("SFTA_Header_Banner_728x90");
</script>
</center>
<nav class="top-navigation-wrapper"><div class="primary-navigation-menu"><ul id="menu-primary" class="menu"><li id="menu-item-176006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-176006"><a title="Home" href="http://straightfromthea.com/">Home</a></li>
<li id="menu-item-198946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-198946"><a href="http://straightfromthea.com/gallery">Photos</a></li>
<li id="menu-item-176009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176009"><a title="Archives" href="http://straightfromthea.com/archives/">Archives</a></li>
<li id="menu-item-176008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176008"><a title="Advertise" href="http://straightfromthea.com/advertise/">Advertise</a></li>
<li id="menu-item-176012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176012"><a title="About" href="http://straightfromthea.com/about/">About</a></li>
<li id="menu-item-176011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176011"><a title="Contact" href="http://straightfromthea.com/contact/">Contact</a></li>
<li id="menu-item-176007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176007"><a title="DMCA" href="http://straightfromthea.com/dmca/">DMCA</a></li>
<li id="menu-item-230886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230886"><a href="https://teespring.com/stores/atlien">Shop</a></li>
</ul></div></nav>
<br />
<div class="featured-wrapper">
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/" rel="bookmark" title="5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230;">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2018/11/IMG_7133-2-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2018/11/IMG_7133-2-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2018/11/IMG_7133-2-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2018/11/IMG_7133-2-144x144.png 144w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2018/11/real-housewives-of-atlanta-season-11-hero-1104-eva-gets-confronted-by-all-the-wives-520x295.jpg" alt="5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230;" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/" rel="bookmark" title="5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230;">5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230;</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/" rel="bookmark" title="ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-3-190x190.jpg" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-3-144x144.jpg 144w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-Masin-Elije-2018-520x466.png" alt="ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/" rel="bookmark" title="ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2018/11/26/another-one-futures-latest-baby-mama-wants-you-to-know-something/" rel="bookmark" title="Another One! Future&#8217;s Latest Baby Mama Wants You To Know Something&#8230;">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant-144x144.png 144w" sizes="(max-width: 190px) 100vw, 190px" /><img src="http://straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant-520x530.png" alt="Another One! Future&#8217;s Latest Baby Mama Wants You To Know Something&#8230;" class="catchthatimg" style="width:190px;height:190px;" />
</a>
</div>
<h4><a href="http://straightfromthea.com/2018/11/26/another-one-futures-latest-baby-mama-wants-you-to-know-something/" rel="bookmark" title="Another One! Future&#8217;s Latest Baby Mama Wants You To Know Something&#8230;">Another One! Future&#8217;s Latest Baby Mama Wants You To Know Something&#8230;</a></h4>
</div>
<div class="featuredad">
<br>
<center><script type='text/javascript'>GA_googleFillSlot("SFTA_Header_Cube_300x250");</script></center>
</div>
<div class="clear"></div>
</div><ul id="main">
<li id="content">
<div class="post-233592 post type-post status-publish format-standard has-post-thumbnail hentry category-atlanta-gossip category-news tag-donald-glover tag-rihanna" id="post-233592">
<div class='shareaholic-canvas' data-app='share_buttons' data-title='Sneak Peek: Clip of Donald Glover &amp; Rihanna&#039;s Secret Movie Project Leaks Online... (VIDEO)' data-link='http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/' data-app-id='14600962'></div><h1 class="storytitle"><a href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/" rel="bookmark">Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)</a></h1>
<div class="meta">
Nov, 26 2018 | Written by ATLien </div>
<div class="storycontent">
<p><center><a href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/rihanna-and-donald-glover/" rel="attachment wp-att-233598"><img src="http://straightfromthea.com/wp-content/uploads/2018/11/Rihanna-and-Donald-Glover-520x377.png" alt="" width="520" height="377" class="alignnone size-large wp-image-233598" srcset="http://straightfromthea.com/wp-content/uploads/2018/11/Rihanna-and-Donald-Glover-520x377.png 520w, http://straightfromthea.com/wp-content/uploads/2018/11/Rihanna-and-Donald-Glover-300x217.png 300w, http://straightfromthea.com/wp-content/uploads/2018/11/Rihanna-and-Donald-Glover-640x464.png 640w, http://straightfromthea.com/wp-content/uploads/2018/11/Rihanna-and-Donald-Glover.png 729w" sizes="(max-width: 520px) 100vw, 520px" /></a></center></p>
<p>Donald Glover surprised festival-goers attending his Pharos Festival in New Zealand this past weekend when he debuted the trailer for his mysterious upcoming cinematic collaboration with Rihanna.</p>
<p>The film, reportedly titled Guava Island, is believed to have been shot in Cuba this past Summer.</p>
<p>Shortly after the debut, smartphone footage of the super secret movie project leaked online. </p>
<p>Details + sneak peek video below&#8230;<span id="more-233592"></span></p>
<p><center><iframe width="560" height="315" src="https://www.youtube.com/embed/Wbxo3LgEUOg" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></center></p>
<p>Glover and Rihanna’s characters appear to be involved in a relationship and music is the primary focus of the movie, which the trailer notes is a &#8216;Childish Gambino film&#8217;.</p>
<p>Letitia Wright and Nonso Anozie co-star in the film, which is directed by Hiro Murai (the man behind many episodes of Glover’s wildly popular &#8216;Atlanta&#8217; TV show and his “This is America” music video).</p>
<p>Glover works a menial day job though his passion lies in playing guitar, his character can be heard stating: “We live in paradise but none of us actually have the time or the means to live here.”</p>
<p>For the record, the rumored title of “Guava Island” has yet to be officially confirmed, much less a release date for the secretive project.</p>
<p><center></p>
<h2>What are your thoughts about the leaked trailer?</center></h2>
<div class="zem_rp_wrap zem_rp_th_vertical_m" id="zem_rp_first"><div class="zem_rp_content"><h3 class="related_post_title">Related Posts</h3><ul class="related_post zem_rp"><li data-position="0" data-poid="in-223014" data-post-type="none"><a href="http://straightfromthea.com/2018/01/08/sneak-peek-atlantafx-season-two-teaser-released-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/01/Atlanta-Season-2-Returns-StraightFromTheA-150x150.jpg" alt="Sneak Peek! #AtlantaFX Season Two Teaser Released&#8230; (VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/01/08/sneak-peek-atlantafx-season-two-teaser-released-video/" class="zem_rp_title">Sneak Peek! #AtlantaFX Season Two Teaser Released&#8230; (VIDEO)</a></li><li data-position="1" data-poid="in-207520" data-post-type="none"><a href="http://straightfromthea.com/2017/01/09/donald-glover-atlantafx-win-big-at-2017-golden-globe-awards-photos-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2017/01/Screen-Shot-2017-01-09-at-9.23.28-AM-150x150.png" alt="Donald Glover &#038; #AtlantaFx Win Big At 2017 Golden Globe Awards&#8230; (PHOTOS + VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2017/01/09/donald-glover-atlantafx-win-big-at-2017-golden-globe-awards-photos-video/" class="zem_rp_title">Donald Glover &#038; #AtlantaFx Win Big At 2017 Golden Globe Awards&#8230; (PHOTOS + VIDEO)</a></li><li data-position="2" data-poid="in-225059" data-post-type="none"><a href="http://straightfromthea.com/2018/02/28/donald-glover-cast-of-atlantafx-robbin-season-host-premiere-at-starlight-drive-in-photos/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2018/02/FX_atlanta_credit_TonyaWise022618_062-150x150.jpg" alt="Donald Glover &#038; Cast of #AtlantaFx &#8216;Robbin&#8217; Season&#8217; Host Premiere At Starlight Drive-In&#8230; (PHOTOS + TRAILER)" width="150" height="150" /></a><a href="http://straightfromthea.com/2018/02/28/donald-glover-cast-of-atlantafx-robbin-season-host-premiere-at-starlight-drive-in-photos/" class="zem_rp_title">Donald Glover &#038; Cast of #AtlantaFx &#8216;Robbin&#8217; Season&#8217; Host Premiere At Starlight Drive-In&#8230; (PHOTOS + TRAILER)</a></li><li data-position="3" data-poid="in-204164" data-post-type="none"><a href="http://straightfromthea.com/2016/11/04/in-case-you-missed-it-atlantafx-episode-10-the-jacket-full-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2016/11/AtlantaFX-Finale-Episode-2016-150x150.jpg" alt="In Case You Missed It: #AtlantaFX Episode 10: &#8216;The Jacket&#8217;&#8230; (FULL VIDEO)" width="150" height="150" /></a><a href="http://straightfromthea.com/2016/11/04/in-case-you-missed-it-atlantafx-episode-10-the-jacket-full-video/" class="zem_rp_title">In Case You Missed It: #AtlantaFX Episode 10: &#8216;The Jacket&#8217;&#8230; (FULL VIDEO)</a></li><li data-position="4" data-poid="in-7260" data-post-type="none"><a href="http://straightfromthea.com/2008/11/10/maybe-it-was-the-eggs/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/plugins/related-posts-by-zemanta/static/thumbs/28.jpg" alt="Maybe It Was The Eggs&#8230;" width="150" height="150" /></a><a href="http://straightfromthea.com/2008/11/10/maybe-it-was-the-eggs/" class="zem_rp_title">Maybe It Was The Eggs&#8230;</a></li></ul></div></div>
<div class='shareaholic-canvas' data-app='share_buttons' data-title='Sneak Peek: Clip of Donald Glover &amp; Rihanna&#039;s Secret Movie Project Leaks Online... (VIDEO)' data-link='http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/' data-app-id='14600957' data-app-id-name='post_below_content'></div>
<div class="pagination-wrapper">
</div>
</div>
<div style="font-size:10px;"><em> In <a href="http://straightfromthea.com/category/atlanta-gossip/" rel="category tag">Atlanta Gossip</a>,<a href="http://straightfromthea.com/category/news/" rel="category tag">News</a> <a href="http://straightfromthea.com/tag/donald-glover/" rel="tag">Donald Glover</a>, <a href="http://straightfromthea.com/tag/rihanna/" rel="tag">Rihanna</a></em></div>
<div id="rcjsload_939d4c"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "http://trends.revcontent.com/serve.js.php?w=79590&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_939d4c"); rcds.appendChild(rcel);
})();
</script>
<div class="feedback">
</div>
</div>
<div class="adspot">
<center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8098644933888050" data-ad-slot="9114578170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
<div class="comments" id="comments">
<div id="disqus_thread"></div>
</div>
<div class="navigation">
<div class="alignleft"></div>
<div class="alignright"></div>
</div>
</li>
<li id="sidebar">
<ul>
<center>
<script type='text/javascript'>
GA_googleFillSlot("SFTA_CUBE_TOP_Right_300x250");
</script></center>
<li id="adspot">
<ul class="sidebar">
<div id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><ul><li><a href="https://www.facebook.com/straightfromthea/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View straightfromthea&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/ATLien/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View ATLien&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/iamatlien/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View iamatlien&#8217;s profile on Instagram</span></a></li><li><a href="https://www.linkedin.com/in/michelledbrown/" class="genericon genericon-linkedin" target="_blank"><span class="screen-reader-text">View michelledbrown&#8217;s profile on LinkedIn</span></a></li><li><a href="https://www.youtube.com/channel/UCcYwBgVSgvU1J830VqOInXQ/" class="genericon genericon-youtube" target="_blank"><span class="screen-reader-text">View UCcYwBgVSgvU1J830VqOInXQ&#8217;s profile on YouTube</span></a></li><li><a href="https://vimeo.com/ATLien/" class="genericon genericon-vimeo" target="_blank"><span class="screen-reader-text">View ATLien&#8217;s profile on Vimeo</span></a></li><li><a href="https://plus.google.com/u/0/+MichelleBrownATL/" class="genericon genericon-googleplus" target="_blank"><span class="screen-reader-text">View +MichelleBrownATL&#8217;s profile on Google+</span></a></li><li><a href="https://atlien.tumblr.com" class="genericon genericon-tumblr" target="_blank"><span class="screen-reader-text">View atlien&#8217;s profile on Tumblr</span></a></li></ul></div><div id="text-459501738" class="widget widget_text"> <div class="textwidget"><p><script data-config="//config.playwire.com/1003736/playlists/v2/4443/zeus.json" src="//cdn.playwire.com/bolt/js/zeus/embed.js"></script></p>
</div>
</div><div id="text-459501718" class="widget widget_text"><h4>Subscribe</h4> <div class="textwidget"><center><form class="feedburner-wrapper" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=sfta', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter email address to receive StraightFromTheA.com updates in your inbox:</p>
<p>Enter your email address:</p>
<p><input class="txt type=" text" name="email" />
<input type="hidden" value="sfta" name="uri" />
<input type="hidden" name="loc" value="en_US" />
<input class="btn" type="submit" value="Subscribe" />
</form></p></center></div>
</div></ul>
</li>
<li id="left">
<ul class="sidebar">
<div id="top-posts-6" class="widget widget_top-posts"><ul class='widgets-list-layout no-grav'>
<li>
<a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/" title="ON BLAST! Dwight Howard &quot;Exposed&quot; Online By Ex-Boy/Girl friend..." class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2018/11/Dwight-Howard-3.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="ON BLAST! Dwight Howard &quot;Exposed&quot; Online By Ex-Boy/Girl friend..." data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/" class="bump-view" data-bump-view="tp">
ON BLAST! Dwight Howard &quot;Exposed&quot; Online By Ex-Boy/Girl friend... </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2018/11/26/another-one-futures-latest-baby-mama-wants-you-to-know-something/" title="Another One! Future&#039;s Latest Baby Mama Wants You To Know Something..." class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2018/11/Future-Eliza-Reign-Pregnant.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Another One! Future&#039;s Latest Baby Mama Wants You To Know Something..." data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2018/11/26/another-one-futures-latest-baby-mama-wants-you-to-know-something/" class="bump-view" data-bump-view="tp">
Another One! Future&#039;s Latest Baby Mama Wants You To Know Something... </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2018/11/26/sean-diddy-combs-delivers-emotional-eulogy-at-kim-porters-funeral-full-video/" title="Sean &#039;Diddy&#039; Combs Delivers Emotional Eulogy At Kim Porter&#039;s Funeral... (FULL VIDEO)" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/straightfromthea.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-24-at-10.39.34-PM.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Sean &#039;Diddy&#039; Combs Delivers Emotional Eulogy At Kim Porter&#039;s Funeral... (FULL VIDEO)" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2018/11/26/sean-diddy-combs-delivers-emotional-eulogy-at-kim-porters-funeral-full-video/" class="bump-view" data-bump-view="tp">
Sean &#039;Diddy&#039; Combs Delivers Emotional Eulogy At Kim Porter&#039;s Funeral... (FULL VIDEO) </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/" title="5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video..." class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2018/11/IMG_7133-2.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video..." data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/" class="bump-view" data-bump-view="tp">
5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video... </a>
</div>
</li>
<li>
<a href="http://straightfromthea.com/2018/11/26/oprah-winfreys-mother-vernita-lee-has-died-at-age-83/" title="Vernita Lee, Mother of Oprah, Dead at Age 83 + Winfrey Posts Touching Tribute... (PHOTOS + VIDEO)" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i1.wp.com/straightfromthea.com/wp-content/uploads/2018/11/Vernita-Lee-Oprah-Winfrey.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Vernita Lee, Mother of Oprah, Dead at Age 83 + Winfrey Posts Touching Tribute... (PHOTOS + VIDEO)" data-pin-nopin="true" />
</a>
<div class="widgets-list-layout-links">
<a href="http://straightfromthea.com/2018/11/26/oprah-winfreys-mother-vernita-lee-has-died-at-age-83/" class="bump-view" data-bump-view="tp">
Vernita Lee, Mother of Oprah, Dead at Age 83 + Winfrey Posts Touching Tribute... (PHOTOS + VIDEO) </a>
</div>
</li>
</ul>
</div><div id="archives-2" class="widget widget_archive"><h4>Archives</h4> <label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
<option value="">Select Month</option>
<option value='http://straightfromthea.com/2018/11/'> November 2018 &nbsp;(44)</option>
<option value='http://straightfromthea.com/2018/10/'> October 2018 &nbsp;(60)</option>
<option value='http://straightfromthea.com/2018/09/'> September 2018 &nbsp;(55)</option>
<option value='http://straightfromthea.com/2018/08/'> August 2018 &nbsp;(67)</option>
<option value='http://straightfromthea.com/2018/07/'> July 2018 &nbsp;(41)</option>
<option value='http://straightfromthea.com/2018/06/'> June 2018 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2018/05/'> May 2018 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2018/04/'> April 2018 &nbsp;(64)</option>
<option value='http://straightfromthea.com/2018/03/'> March 2018 &nbsp;(50)</option>
<option value='http://straightfromthea.com/2018/02/'> February 2018 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2018/01/'> January 2018 &nbsp;(105)</option>
<option value='http://straightfromthea.com/2017/12/'> December 2017 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2017/11/'> November 2017 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2017/10/'> October 2017 &nbsp;(88)</option>
<option value='http://straightfromthea.com/2017/09/'> September 2017 &nbsp;(77)</option>
<option value='http://straightfromthea.com/2017/08/'> August 2017 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2017/07/'> July 2017 &nbsp;(86)</option>
<option value='http://straightfromthea.com/2017/06/'> June 2017 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2017/05/'> May 2017 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2017/04/'> April 2017 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2017/03/'> March 2017 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2017/02/'> February 2017 &nbsp;(73)</option>
<option value='http://straightfromthea.com/2017/01/'> January 2017 &nbsp;(86)</option>
<option value='http://straightfromthea.com/2016/12/'> December 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/11/'> November 2016 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2016/10/'> October 2016 &nbsp;(70)</option>
<option value='http://straightfromthea.com/2016/09/'> September 2016 &nbsp;(61)</option>
<option value='http://straightfromthea.com/2016/08/'> August 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/07/'> July 2016 &nbsp;(55)</option>
<option value='http://straightfromthea.com/2016/06/'> June 2016 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2016/05/'> May 2016 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2016/04/'> April 2016 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2016/03/'> March 2016 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2016/02/'> February 2016 &nbsp;(66)</option>
<option value='http://straightfromthea.com/2016/01/'> January 2016 &nbsp;(66)</option>
<option value='http://straightfromthea.com/2015/12/'> December 2015 &nbsp;(53)</option>
<option value='http://straightfromthea.com/2015/11/'> November 2015 &nbsp;(67)</option>
<option value='http://straightfromthea.com/2015/10/'> October 2015 &nbsp;(73)</option>
<option value='http://straightfromthea.com/2015/09/'> September 2015 &nbsp;(76)</option>
<option value='http://straightfromthea.com/2015/08/'> August 2015 &nbsp;(58)</option>
<option value='http://straightfromthea.com/2015/07/'> July 2015 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2015/06/'> June 2015 &nbsp;(83)</option>
<option value='http://straightfromthea.com/2015/05/'> May 2015 &nbsp;(70)</option>
<option value='http://straightfromthea.com/2015/04/'> April 2015 &nbsp;(74)</option>
<option value='http://straightfromthea.com/2015/03/'> March 2015 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2015/02/'> February 2015 &nbsp;(79)</option>
<option value='http://straightfromthea.com/2015/01/'> January 2015 &nbsp;(69)</option>
<option value='http://straightfromthea.com/2014/12/'> December 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/11/'> November 2014 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2014/10/'> October 2014 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2014/09/'> September 2014 &nbsp;(63)</option>
<option value='http://straightfromthea.com/2014/08/'> August 2014 &nbsp;(59)</option>
<option value='http://straightfromthea.com/2014/07/'> July 2014 &nbsp;(51)</option>
<option value='http://straightfromthea.com/2014/06/'> June 2014 &nbsp;(56)</option>
<option value='http://straightfromthea.com/2014/05/'> May 2014 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2014/04/'> April 2014 &nbsp;(71)</option>
<option value='http://straightfromthea.com/2014/03/'> March 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/02/'> February 2014 &nbsp;(65)</option>
<option value='http://straightfromthea.com/2014/01/'> January 2014 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2013/12/'> December 2013 &nbsp;(80)</option>
<option value='http://straightfromthea.com/2013/11/'> November 2013 &nbsp;(78)</option>
<option value='http://straightfromthea.com/2013/10/'> October 2013 &nbsp;(103)</option>
<option value='http://straightfromthea.com/2013/09/'> September 2013 &nbsp;(90)</option>
<option value='http://straightfromthea.com/2013/08/'> August 2013 &nbsp;(95)</option>
<option value='http://straightfromthea.com/2013/07/'> July 2013 &nbsp;(76)</option>
<option value='http://straightfromthea.com/2013/06/'> June 2013 &nbsp;(88)</option>
<option value='http://straightfromthea.com/2013/05/'> May 2013 &nbsp;(79)</option>
<option value='http://straightfromthea.com/2013/04/'> April 2013 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2013/03/'> March 2013 &nbsp;(92)</option>
<option value='http://straightfromthea.com/2013/02/'> February 2013 &nbsp;(82)</option>
<option value='http://straightfromthea.com/2013/01/'> January 2013 &nbsp;(95)</option>
<option value='http://straightfromthea.com/2012/12/'> December 2012 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2012/11/'> November 2012 &nbsp;(81)</option>
<option value='http://straightfromthea.com/2012/10/'> October 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2012/09/'> September 2012 &nbsp;(85)</option>
<option value='http://straightfromthea.com/2012/08/'> August 2012 &nbsp;(104)</option>
<option value='http://straightfromthea.com/2012/07/'> July 2012 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2012/06/'> June 2012 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2012/05/'> May 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2012/04/'> April 2012 &nbsp;(122)</option>
<option value='http://straightfromthea.com/2012/03/'> March 2012 &nbsp;(120)</option>
<option value='http://straightfromthea.com/2012/02/'> February 2012 &nbsp;(134)</option>
<option value='http://straightfromthea.com/2012/01/'> January 2012 &nbsp;(129)</option>
<option value='http://straightfromthea.com/2011/12/'> December 2011 &nbsp;(102)</option>
<option value='http://straightfromthea.com/2011/11/'> November 2011 &nbsp;(110)</option>
<option value='http://straightfromthea.com/2011/10/'> October 2011 &nbsp;(127)</option>
<option value='http://straightfromthea.com/2011/09/'> September 2011 &nbsp;(132)</option>
<option value='http://straightfromthea.com/2011/08/'> August 2011 &nbsp;(123)</option>
<option value='http://straightfromthea.com/2011/07/'> July 2011 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2011/06/'> June 2011 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2011/05/'> May 2011 &nbsp;(112)</option>
<option value='http://straightfromthea.com/2011/04/'> April 2011 &nbsp;(114)</option>
<option value='http://straightfromthea.com/2011/03/'> March 2011 &nbsp;(130)</option>
<option value='http://straightfromthea.com/2011/02/'> February 2011 &nbsp;(134)</option>
<option value='http://straightfromthea.com/2011/01/'> January 2011 &nbsp;(141)</option>
<option value='http://straightfromthea.com/2010/12/'> December 2010 &nbsp;(135)</option>
<option value='http://straightfromthea.com/2010/11/'> November 2010 &nbsp;(141)</option>
<option value='http://straightfromthea.com/2010/10/'> October 2010 &nbsp;(154)</option>
<option value='http://straightfromthea.com/2010/09/'> September 2010 &nbsp;(122)</option>
<option value='http://straightfromthea.com/2010/08/'> August 2010 &nbsp;(109)</option>
<option value='http://straightfromthea.com/2010/07/'> July 2010 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2010/06/'> June 2010 &nbsp;(160)</option>
<option value='http://straightfromthea.com/2010/05/'> May 2010 &nbsp;(148)</option>
<option value='http://straightfromthea.com/2010/04/'> April 2010 &nbsp;(148)</option>
<option value='http://straightfromthea.com/2010/03/'> March 2010 &nbsp;(144)</option>
<option value='http://straightfromthea.com/2010/02/'> February 2010 &nbsp;(116)</option>
<option value='http://straightfromthea.com/2010/01/'> January 2010 &nbsp;(124)</option>
<option value='http://straightfromthea.com/2009/12/'> December 2009 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2009/11/'> November 2009 &nbsp;(82)</option>
<option value='http://straightfromthea.com/2009/10/'> October 2009 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2009/09/'> September 2009 &nbsp;(96)</option>
<option value='http://straightfromthea.com/2009/08/'> August 2009 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2009/07/'> July 2009 &nbsp;(89)</option>
<option value='http://straightfromthea.com/2009/06/'> June 2009 &nbsp;(117)</option>
<option value='http://straightfromthea.com/2009/05/'> May 2009 &nbsp;(93)</option>
<option value='http://straightfromthea.com/2009/04/'> April 2009 &nbsp;(128)</option>
<option value='http://straightfromthea.com/2009/03/'> March 2009 &nbsp;(119)</option>
<option value='http://straightfromthea.com/2009/02/'> February 2009 &nbsp;(105)</option>
<option value='http://straightfromthea.com/2009/01/'> January 2009 &nbsp;(99)</option>
<option value='http://straightfromthea.com/2008/12/'> December 2008 &nbsp;(72)</option>
<option value='http://straightfromthea.com/2008/11/'> November 2008 &nbsp;(111)</option>
<option value='http://straightfromthea.com/2008/10/'> October 2008 &nbsp;(137)</option>
<option value='http://straightfromthea.com/2008/09/'> September 2008 &nbsp;(132)</option>
<option value='http://straightfromthea.com/2008/08/'> August 2008 &nbsp;(153)</option>
<option value='http://straightfromthea.com/2008/07/'> July 2008 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2008/06/'> June 2008 &nbsp;(111)</option>
<option value='http://straightfromthea.com/2008/05/'> May 2008 &nbsp;(123)</option>
<option value='http://straightfromthea.com/2008/04/'> April 2008 &nbsp;(121)</option>
<option value='http://straightfromthea.com/2008/03/'> March 2008 &nbsp;(143)</option>
<option value='http://straightfromthea.com/2008/02/'> February 2008 &nbsp;(94)</option>
<option value='http://straightfromthea.com/2008/01/'> January 2008 &nbsp;(60)</option>
<option value='http://straightfromthea.com/2007/12/'> December 2007 &nbsp;(29)</option>
<option value='http://straightfromthea.com/2007/11/'> November 2007 &nbsp;(26)</option>
<option value='http://straightfromthea.com/2007/10/'> October 2007 &nbsp;(25)</option>
<option value='http://straightfromthea.com/2007/09/'> September 2007 &nbsp;(28)</option>
<option value='http://straightfromthea.com/2007/08/'> August 2007 &nbsp;(21)</option>
</select>
</div><div id="recent-comments-4" class="widget widget_recent_comments"><h4>Who&#8217;s Talking?</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536245">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536246">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536247">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536248">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536250">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536249">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/#comment-5536244">Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536251">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536252">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/" rel='external nofollow' class='url'>Anonymous</a></span> on <a href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/#comment-5536253">ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230;</a></li></ul></div></ul>
</li>
<li id="right">
<ul class="sidebar">
<center>
<br></br>
<script type='text/javascript'>
GA_googleFillSlot("SFTA_RightSidebar_ROS1");
</script>

<br></br>

<script type='text/javascript'>
GA_googleFillSlot("SFTA_Sidebar_Middle_160x600");
</script>

</br>

<script type='text/javascript'>
GA_googleFillSlot("SFTA_Sidebar_3_160x600");
</script>

</center>
</ul>
</li>
<li class="clear">&nbsp;</li>
<li id="belowadspot">
<ul class="sidebar">
<div id="custom_html-4" class="widget_text widget widget_custom_html"><h4>ATLien&#8217;s Blogging Masterclass</h4><div class="textwidget custom-html-widget"><style>

.bloggingcoursesignup {background-color:#222;padding:1em 1em 50px 1em;margin-bottom:1em;} 
.bloggingcoursesignup h5 {border-bottom:5px solid #ffc600;font-size:12pt;margin-bottom:1em;padding:1em;text-align:center;}
.bloggingcoursesignup form input {background-color:#444;border:0;color:#fff;font-size:13pt;font-weight:bold;padding:.3em .5em;text-align:center;text-shadow:1px 1px 1px #000;}
.bloggingcoursesignup form input:hover {background-color:#fff;box-shadow:0em 0em 2em #fff;color:#000;text-shadow:0 0 0 #000;}
.bloggingcoursesignup form input.button {background-color:#900;border:5px solid #900;color:#fff;display:block;font-size:10pt;margin:1em auto;text-align:center;padding:1em;}
.bloggingcoursesignup form input.button:hover {box-shadow:0em 0em 2em #600;border:5px solid #900;color:#900;background-color:#fff;cursor:pointer;}
.bloggingcoursesignup form .mc-field-group {text-align:center;background-color:#333;margin:.1em auto;padding:.4em 1em;}
</style>

<div id="mc_embed_signup" class="bloggingcoursesignup">
<form action="https://straightfromthea.us12.list-manage.com/subscribe/post?u=245c753ee0169e7eb7618bc72&amp;id=1e69dc53df" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<h5>ATLien Will Teach the In's and Out's of Creating a Web Presence in the Social Media age.</h5>
<div class="mc-field-group">
<label for="mce-EMAIL">Email Address </label>
<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group">
<label for="mce-FNAME">First Name </label>
<input type="text" value="" name="FNAME" class="" id="mce-FNAME" />
</div>
<div class="mc-field-group">
<label for="mce-LNAME">Last Name </label>
<input type="text" value="" name="LNAME" class="" id="mce-LNAME" />
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none">
</div>
<div class="response" id="mce-success-response" style="display:none">
</div>
</div> 
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_245c753ee0169e7eb7618bc72_1e69dc53df" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div><div id="text-459501717" class="widget widget_text"><h4>Social Networks</h4> <div class="textwidget"><div style="display:block;margin:0 auto;text-align:center"><a title="ATLien's Tumblr (Personal Site)" href="http://iamATLien.com" target="_blank"><img title="iamATLien.com" alt="iamATLien.com" src="http://straightfromthea.com/wp-content/uploads/2012/06/fullscreen_capture_582011_123314_am.bmp-300x110.jpg" /></a></div>
</div>
</div><div id="text-459501740" class="widget widget_text"><h4>YouTube</h4> <div class="textwidget"><p><center><iframe src="https://www.youtube.com/embed/videoseries?list=PLb0WfR6_7lxaQQljq-9CZ7ooSYpIXfb_9" frameborder="0" allowfullscreen=""></iframe></center></p>
<p class="text-center" style="text-align: center;"><strong>SUBSCRIBE</strong>:<a style="display: block; margin: 0 auto; text-align: center;" title="ATLien on YouTube" href="https://www.youtube.com/c/atlien?sub_confrimation=1"> ATLien on YouTube</a></p>
</div>
</div><div id="custom_html-5" class="widget_text widget widget_custom_html"><h4>Join The A-SQUAD</h4><div class="textwidget custom-html-widget"><div class="fb-group" data-href="https://www.facebook.com/groups/205126650085285/" data-width="300" data-show-social-context="true" data-show-metadata="true" style="width:100%;"></div></div></div><div id="text-459501728" class="widget widget_text"><h4>Like Us on Facebook</h4> <div class="textwidget"><center><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FStraightFromTheA%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=527308440666890" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></center></div>
</div><div id="text-459501724" class="widget widget_text"><h4>Instagram</h4> <div class="textwidget"><div id="sb_instagram" class="sbi sbi_mob_col_auto sbi_fixed_height  sbi_col_4" style="width:340px; height:340px; background-color: #0a0400; padding-bottom: 4px; " data-id="3061145" data-num="8" data-res="auto" data-cols="4" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;showbio&quot;: &quot;false&quot;,&quot;feedID&quot;: &quot;3061145&quot;, &quot;headercolor&quot;: &quot;&quot;, &quot;imagepadding&quot;: &quot;2&quot;,&quot;mid&quot;: &quot;M2E4MWE5Zg==&quot;, &quot;disablecache&quot;: &quot;false&quot;, &quot;sbiCacheExists&quot;: &quot;false&quot;,&quot;callback&quot;: &quot;Y2YwMjUwZjQwMGY4NDJ.hYWI5OTFlYTAzZWJhM2Q1YmY=&quot;, &quot;sbiHeaderCache&quot;: &quot;false&quot;}'><div class="sb_instagram_header" style="padding: 4px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 2px;"><div class="sbi_loader"></div></div><div id="sbi_load" class="sbi_hidden"><a class="sbi_load_btn" href="javascript:void(0);" style="display: none; "><span class="sbi_btn_text">Load More...</span><div class="sbi_loader sbi_hidden"></div></a><div class="sbi_follow_btn"><a href="https://www.instagram.com/" style="" target="_blank"><i class="fa fab fa-instagram"></i>Follow on Instagram</a></div></div></div></div>
</div><div id="custom_html-3" class="widget_text widget widget_custom_html"><h4>ATLien for Dramatic Weight Loss</h4><div class="textwidget custom-html-widget"><center><iframe src="https://www.youtube.com/embed/videoseries?list=PLN6faKO2z1jcD2RvSFMzyBdSiDQtabcZD" width="300" height="260" frameborder="0" allowfullscreen=""></iframe></center>
<center>READ: <a href="http://straightfromthea.com/2011/09/20/atlien-dramatic-weight-loss-at-fso20/" target="_blank">My Ode to Dramatic Weight Loss (PHOTOS)</a></center>
<center>**StraightFromTheA.com readers receive special discount:</center>
<center><a href="http://straightfromthea.com/wp-content/uploads/2010/12/SFTA-DWL-coupon.pdf">CLICK HERE</a> for Discount Coupon!</center>
<center><script src="//ap.lijit.com/www/delivery/fpi.js?z=450117&width=300&height=250"></script> </center></div></div></ul>
</li>
</ul>
</li>
<li class="clear">&nbsp;</li>
</ul>
</div>
<div class="row" id="bottoms">
<div class="col-lg-12 col-md-12 col-sm-12 col-xs-12 more-wrapper">
<div class="col-lg-4 col-md-4 bottomleft-wrapper">
<h5>Page 1</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/oprah-winfreys-mother-vernita-lee-has-died-at-age-83/" title="">
Vernita Lee, Mother of Oprah, Dead at Age 83 + Winfrey Posts Touching Tribute&#8230; (PHOTOS + VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/5-things-revealed-on-rhoa-season-11-episode-4-pass-the-peach-throw-the-shade-watch-full-video/" title="">
5 Things Revealed on #RHOA Season 11, Episode 4: Pass the Peach, Throw the Shade + Watch Full Video&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video/" title="">
Sneak Peek: Clip of Donald Glover &#038; Rihanna&#8217;s Secret Movie Project Leaks Online&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/on-blast-dwight-howard-exposed-online-by-ex-boy-girl-friend/" title="">
ON BLAST! Dwight Howard &#8220;Exposed&#8221; Online By Ex-Boy/Girl friend&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/another-one-futures-latest-baby-mama-wants-you-to-know-something/" title="">
Another One! Future&#8217;s Latest Baby Mama Wants You To Know Something&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/26/sean-diddy-combs-delivers-emotional-eulogy-at-kim-porters-funeral-full-video/" title="">
Sean &#8216;Diddy&#8217; Combs Delivers Emotional Eulogy At Kim Porter&#8217;s Funeral&#8230; (FULL VIDEO) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="col-lg-4 col-md-4 bottommid-wrapper">
<h5>Page 2</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/19/porsha-williams-calls-kandi-burruss-hateful-miserable-on-watch-what-happens-live-photos-video/" title="">
Porsha Williams Calls Kandi Burruss &#8216;Hateful &#038; Miserable&#8217; On &#8216;Watch What Happens LIVE!&#8217;&#8230; (PHOTOS + VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/19/recap-5-things-revealed-on-rhoa-season-11-episode-3-a-new-addition-watch-full-video/" title="">
RECAP: 5 Things Revealed on #RHOA Season 11, Episode 3 &#8220;A New Addition&#8221; + WATCH FULL VIDEO&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/17/baby-bump-watch-rhoa-porsha-williams-rocks-her-first-traditional-maternity-dress-photos/" title="">
Baby Bump Watch: #RHOA Porsha Williams Rocks Her First &#8216;Traditional&#8217; Maternity Dress&#8230; (PHOTOS) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/16/forever-my-lady-al-b-sure-posts-tribute-to-kim-porter/" title="">
“Forever My Lady” &#8211; Al B. Sure! Posts Touching Tribute to Kim Porter&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/16/rhoa-kandi-burruss-wants-bff-kenya-moore-back-on-housewives-shes-good-for-the-show-video/" title="">
#RHOA Kandi Burruss Wants &#8216;BFF&#8217; Kenya Moore Back On &#8216;Housewives&#8217;: &#8216;She&#8217;s Good For The Show&#8217;&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/16/kaavia-james-union-wade/" title="">
Dwayne Wade &#038; Gabrielle Union&#8217;s Miracle Baby Name Revealed&#8230; (PHOTOS) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="col-lg-4 col-md-4 bottomright-wrapper">
<h5>Page 3</h5>
<ul class="bottom-posts">
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/16/no-food-no-play-tamar-braxton-reportedly-bails-on-stage-performance-after-failed-food-delivery/" title="">
No Food? No Play! Tamar Braxton Reportedly Bails on Stage Performance After Failed Food Delivery&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/15/kim-porter-diddys-ex-found-dead-at-47/" title="">
Kim Porter, Diddy&#8217;s Ex and Mother of 4, Found Dead at 47&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/15/neo-soul-shade-jaguar-wright-criticizes-jill-scotts-microphone-fellatio-trick-video/" title="">
Neo-Soul Shade! Jaguar Wright Criticizes Jill Scott&#8217;s Salacious Microphone Trick&#8230; (VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/15/open-post-who-knew-monica-was-a-mortician-friends-family-hustle-episode-4-full-video/" title="">
OPEN POST: Who Knew Monica Brown Was A Mortician?!? &#8216;Friends &#038; Family Hustle&#8217; Episode 4 (FULL VIDEO) </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/15/rumor-control-erykah-badu-responds-to-pregnancy-rumors/" title="">
RUMOR CONTROL: Erykah Badu Responds To Pregnancy Rumors&#8230; </a>
</h4>
</header>
</li>
<li class="bottom-post">
<header class="article-header post-header">
<h4 class="article-title post-title">
<a class="title-link" href="http://straightfromthea.com/2018/11/15/bood-up-rhoa-cynthia-bailey-and-season-11-boyfriend-mike-hill-hit-promo-circuit-video/" title="">
Boo&#8217;d Up: #RHOA Cynthia Bailey and Season 11 Boyfriend Mike Hill Hit Promo Circuit&#8230; (VIDEO) </a>
</h4>
</header>
</li>
</ul>
</div>
<div class="clear"></div>
</div>
</div>
<div id="footer">
<br />
<center>


<script type='text/javascript'>
GA_googleFillSlot("SFTA_FooterAd_728x90");
</script>

</center>
<center>
<a href="http://straightfromthea.com" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News" style="color:#fff;">&copy; 2007 - 2018 Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News</a><br />
<br />
<p class="credit" id="credit" itemprop="credit"><a class="credit-link" href="http://zillzdesignedit.com/" title="ZILLZDESIGNEDIT"><a href="http://zillzdesignedit.com/"><img src="http://straightfromthea.com/wp-content/uploads/2016/11/zillzdesignedit.png" alt="ZILLZDESIGNEDIT" width="70" height="45" class="alignnone size-full wp-image-204328" /></a></p>
<script id="_wau1b5">var _wau = _wau || []; _wau.push(["small", "47765hfex33c", "1b5"]);
(function() {var s=document.createElement("script"); s.async=true;
s.src="http://widgets.amung.us/small.js";
document.getElementsByTagName("head")[0].appendChild(s);
})();</script></center>
</div>

<script type="text/javascript">
var sbiajaxurl = "http://straightfromthea.com/wp-admin/admin-ajax.php";
</script>
 <div style="display:none">
</div>
<link rel='stylesheet' id='genericons-css' href='http://straightfromthea.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"straightfromthea"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"233592 http:\/\/straightfromthea.com\/?p=233592","disqusShortname":"straightfromthea","disqusTitle":"Sneak Peek: Clip of Donald Glover & Rihanna\u2019s Secret Movie Project Leaks Online\u2026 (VIDEO)","disqusUrl":"http:\/\/straightfromthea.com\/2018\/11\/26\/sneak-peek-clip-of-donald-glover-rihannas-secret-movie-project-leaks-online-video\/","postId":"233592"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"3061145.M2E4MWE5Zg==.Y2YwMjUwZjQwMGY4NDJ.hYWI5OTFlYTAzZWJhM2Q1YmY=","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.10.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201848'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201848.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.7',blog:'39327528',post:'233592',tz:'-4',srv:'straightfromthea.com'} ]);
	_stq.push([ 'clickTrackerInit', '39327528', '233592' ]);
</script>

<script type="text/javascript">
_qoptions={
qacct:"p-fbtLAmt-wiiPM"
};
</script>
<script type="text/javascript" src="https://www.quantserve.com/quant.js"></script>
<noscript>
<a href="http://www.quantcast.com/p-fbtLAmt-wiiPM" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-fbtLAmt-wiiPM.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></a>
</noscript>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5176916-1', 'auto');
  ga('send', 'pageview');

</script>
<script id="dsq-count-scr" src="//straightfromthea.disqus.com/count.js" async></script>
<style>
.shareaholic-canvas {float:left;} .storycontent .shareaholic-canvas {float:none !important;}
</style>
</body>
</html>