
<!DOCTYPE html>
<!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]--><!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]--><!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]--><!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]--><!--[if (gt IE 9)|!(IE)]><!-->
<html class="no-js" dir="ltr" xmlns="http://www.w3.org/1999/xhtml" xmlns:b="http://www.google.com/2005/gml/b" xmlns:c="http://s.opencalais.com/1/pred/" xmlns:ctag="http://commontag.org/ns#" xmlns:data="http://www.google.com/2005/gml/data" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:dcterm="http://purl.org/dc/terms/" xmlns:expr="http://www.google.com/2005/gml/expr" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioctypes="http://rdfs.org/sioc/types#" xmlns:v="http://rdf.data-vocabulary.org/#" xmlns:meebo="http://www.meebo.com" xmlns:addthis="http://www.addthis.com/help/api-spec" itemscope itemtype="http://schema.org/Blog" lang="en-US"><!--<![endif]-->
<head profile="http://gmpg.org/xfn/11">
<title>Remy Ma, Giselle Bryant, Mona Scott Young &#038; More Attend Debra Lee&#8217;s Pre-BET Awards Dinner&#8230; (PHOTOS)
</title>
<meta name="robots" content="index,follow"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta content="Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" name="description"/>
<meta name="y_key" content="a253b756d4a876c5"/>
<meta name="dmoz.id" content=""/>
<meta property="twitter:account_id" content="14174554"/>
<meta name="revisit-after" content="1 days"/>
<meta name="rating" content="General"/>
<meta name="classification" content="Weblog"/>
<meta name="distribution" content="global"/>
<meta name="MSSmartTagsPreventParsing" content="true"/>
<meta name="author" content="ATLien"/>
<meta name="google-site-verification" content="Vd1bL8T_A-b8076YudJJ2IbndwiRwXElhAqh3dlV4H4"/>
<meta name="google-site-verification" content="v14OaPeUZU9C5AnL4MrJqsci05Fupa8MC_jE4E-1nwg"/>
<meta name="google-site-verification" content="jU20Mb9_9KmsJQdSe2GcYvVbMkRwps5eNNcu2aKO56A"/>
<meta name="keywords" content="ATLANTA gossip,phaedra parks,NeNe Leakes,fantasia barrino,celebrity gossip,urban gossip,Big Boi,Outkast,andre 3000,Atlanta,Atlanta Housewives,the real housewives of atlanta,Beyonce,kandi burruss,Rhianna,Ne-Yo,ludacris,cynthia bailey,rumors,sheree whitfield,phaedra parks,hip-hop,goodie mob,love and hip hop atlanta,77UIfg_LokXvsryzwoLDjhWxNBE"/>
<meta name="verify-v1" content="aX4NgU4kvosERqQla4iWMtzN7/HOKCDPc+3FKKrbVzc="/>
<meta name="google-site-verification" content="sLJCSXVOSaUoODbIg7m2cCQniGLDv0u-8nDyc6sGyOU"/>
<script type="text/javascript">
//<![CDATA[
var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-5176916-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();(function(b){(function(a){"__CF"in b&&"DJS"in b.__CF?b.__CF.DJS.push(a):"addEventListener"in b?b.addEventListener("load",a,!1):b.attachEvent("onload",a)})(function(){"FB"in b&&"Event"in FB&&"subscribe"in FB.Event&&(FB.Event.subscribe("edge.create",function(a){_gaq.push(["_trackSocial","facebook","like",a])}),FB.Event.subscribe("edge.remove",function(a){_gaq.push(["_trackSocial","facebook","unlike",a])}),FB.Event.subscribe("message.send",function(a){_gaq.push(["_trackSocial","facebook","send",a])}));"twttr"in b&&"events"in twttr&&"bind"in twttr.events&&twttr.events.bind("tweet",function(a){if(a){var b;if(a.target&&a.target.nodeName=="IFRAME")a:{if(a=a.target.src){a=a.split("#")[0].match(/[^?=&]+=([^&]*)?/g);b=0;for(var c;c=a[b];++b)if(c.indexOf("url")===0){b=unescape(c.split("=")[1]);break a}}b=void 0}_gaq.push(["_trackSocial","twitter","tweet",b])}})})})(window);//]]>
</script><script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:1497991691,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"9a1b10baf83564c0f6580a1ee9ffa307",petok:"018b81e3e38eceb17e64178daa052b1324e753d4-1498229382-3600",zone:"straightfromthea.com",rocket:"0",apps:{"ga_key":{"ua":"UA-5176916-1","ga_bs":"2"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=85b614c0f6/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>
</script>
<link href="http://straightfromthea.com/wp-content/themes/sfta/style.css" type="text/css" rel="stylesheet"/>
<link rel="shortcut icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.ico"/>
<link rel="icon" href="http://cdn.straightfromthea.com/wp-content/uploads/2013/05/favicon.gif" type="image/gif"/>
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://straightfromthea.com/feed/"/>
<link rel="alternate" type="text/xml" title="RSS .92" href="http://straightfromthea.com/feed/rss/"/>
<link rel="alternate" type="application/atom+xml" title="Atom 1.0" href="http://straightfromthea.com/feed/atom/"/>
<link rel="pingback" href="http://straightfromthea.com/xmlrpc.php"/>
<link rel='archives' title='June 2017' href='http://straightfromthea.com/2017/06/'/>
<link rel='archives' title='May 2017' href='http://straightfromthea.com/2017/05/'/>
<link rel='archives' title='April 2017' href='http://straightfromthea.com/2017/04/'/>
<link rel='archives' title='March 2017' href='http://straightfromthea.com/2017/03/'/>
<link rel='archives' title='February 2017' href='http://straightfromthea.com/2017/02/'/>
<link rel='archives' title='January 2017' href='http://straightfromthea.com/2017/01/'/>
<link rel='archives' title='December 2016' href='http://straightfromthea.com/2016/12/'/>
<link rel='archives' title='November 2016' href='http://straightfromthea.com/2016/11/'/>
<link rel='archives' title='October 2016' href='http://straightfromthea.com/2016/10/'/>
<link rel='archives' title='September 2016' href='http://straightfromthea.com/2016/09/'/>
<link rel='archives' title='August 2016' href='http://straightfromthea.com/2016/08/'/>
<link rel='archives' title='July 2016' href='http://straightfromthea.com/2016/07/'/>
<link rel='archives' title='June 2016' href='http://straightfromthea.com/2016/06/'/>
<link rel='archives' title='May 2016' href='http://straightfromthea.com/2016/05/'/>
<link rel='archives' title='April 2016' href='http://straightfromthea.com/2016/04/'/>
<link rel='archives' title='March 2016' href='http://straightfromthea.com/2016/03/'/>
<link rel='archives' title='February 2016' href='http://straightfromthea.com/2016/02/'/>
<link rel='archives' title='January 2016' href='http://straightfromthea.com/2016/01/'/>
<link rel='archives' title='December 2015' href='http://straightfromthea.com/2015/12/'/>
<link rel='archives' title='November 2015' href='http://straightfromthea.com/2015/11/'/>
<link rel='archives' title='October 2015' href='http://straightfromthea.com/2015/10/'/>
<link rel='archives' title='September 2015' href='http://straightfromthea.com/2015/09/'/>
<link rel='archives' title='August 2015' href='http://straightfromthea.com/2015/08/'/>
<link rel='archives' title='July 2015' href='http://straightfromthea.com/2015/07/'/>
<link rel='archives' title='June 2015' href='http://straightfromthea.com/2015/06/'/>
<link rel='archives' title='May 2015' href='http://straightfromthea.com/2015/05/'/>
<link rel='archives' title='April 2015' href='http://straightfromthea.com/2015/04/'/>
<link rel='archives' title='March 2015' href='http://straightfromthea.com/2015/03/'/>
<link rel='archives' title='February 2015' href='http://straightfromthea.com/2015/02/'/>
<link rel='archives' title='January 2015' href='http://straightfromthea.com/2015/01/'/>
<link rel='archives' title='December 2014' href='http://straightfromthea.com/2014/12/'/>
<link rel='archives' title='November 2014' href='http://straightfromthea.com/2014/11/'/>
<link rel='archives' title='October 2014' href='http://straightfromthea.com/2014/10/'/>
<link rel='archives' title='September 2014' href='http://straightfromthea.com/2014/09/'/>
<link rel='archives' title='August 2014' href='http://straightfromthea.com/2014/08/'/>
<link rel='archives' title='July 2014' href='http://straightfromthea.com/2014/07/'/>
<link rel='archives' title='June 2014' href='http://straightfromthea.com/2014/06/'/>
<link rel='archives' title='May 2014' href='http://straightfromthea.com/2014/05/'/>
<link rel='archives' title='April 2014' href='http://straightfromthea.com/2014/04/'/>
<link rel='archives' title='March 2014' href='http://straightfromthea.com/2014/03/'/>
<link rel='archives' title='February 2014' href='http://straightfromthea.com/2014/02/'/>
<link rel='archives' title='January 2014' href='http://straightfromthea.com/2014/01/'/>
<link rel='archives' title='December 2013' href='http://straightfromthea.com/2013/12/'/>
<link rel='archives' title='November 2013' href='http://straightfromthea.com/2013/11/'/>
<link rel='archives' title='October 2013' href='http://straightfromthea.com/2013/10/'/>
<link rel='archives' title='September 2013' href='http://straightfromthea.com/2013/09/'/>
<link rel='archives' title='August 2013' href='http://straightfromthea.com/2013/08/'/>
<link rel='archives' title='July 2013' href='http://straightfromthea.com/2013/07/'/>
<link rel='archives' title='June 2013' href='http://straightfromthea.com/2013/06/'/>
<link rel='archives' title='May 2013' href='http://straightfromthea.com/2013/05/'/>
<link rel='archives' title='April 2013' href='http://straightfromthea.com/2013/04/'/>
<link rel='archives' title='March 2013' href='http://straightfromthea.com/2013/03/'/>
<link rel='archives' title='February 2013' href='http://straightfromthea.com/2013/02/'/>
<link rel='archives' title='January 2013' href='http://straightfromthea.com/2013/01/'/>
<link rel='archives' title='December 2012' href='http://straightfromthea.com/2012/12/'/>
<link rel='archives' title='November 2012' href='http://straightfromthea.com/2012/11/'/>
<link rel='archives' title='October 2012' href='http://straightfromthea.com/2012/10/'/>
<link rel='archives' title='September 2012' href='http://straightfromthea.com/2012/09/'/>
<link rel='archives' title='August 2012' href='http://straightfromthea.com/2012/08/'/>
<link rel='archives' title='July 2012' href='http://straightfromthea.com/2012/07/'/>
<link rel='archives' title='June 2012' href='http://straightfromthea.com/2012/06/'/>
<link rel='archives' title='May 2012' href='http://straightfromthea.com/2012/05/'/>
<link rel='archives' title='April 2012' href='http://straightfromthea.com/2012/04/'/>
<link rel='archives' title='March 2012' href='http://straightfromthea.com/2012/03/'/>
<link rel='archives' title='February 2012' href='http://straightfromthea.com/2012/02/'/>
<link rel='archives' title='January 2012' href='http://straightfromthea.com/2012/01/'/>
<link rel='archives' title='December 2011' href='http://straightfromthea.com/2011/12/'/>
<link rel='archives' title='November 2011' href='http://straightfromthea.com/2011/11/'/>
<link rel='archives' title='October 2011' href='http://straightfromthea.com/2011/10/'/>
<link rel='archives' title='September 2011' href='http://straightfromthea.com/2011/09/'/>
<link rel='archives' title='August 2011' href='http://straightfromthea.com/2011/08/'/>
<link rel='archives' title='July 2011' href='http://straightfromthea.com/2011/07/'/>
<link rel='archives' title='June 2011' href='http://straightfromthea.com/2011/06/'/>
<link rel='archives' title='May 2011' href='http://straightfromthea.com/2011/05/'/>
<link rel='archives' title='April 2011' href='http://straightfromthea.com/2011/04/'/>
<link rel='archives' title='March 2011' href='http://straightfromthea.com/2011/03/'/>
<link rel='archives' title='February 2011' href='http://straightfromthea.com/2011/02/'/>
<link rel='archives' title='January 2011' href='http://straightfromthea.com/2011/01/'/>
<link rel='archives' title='December 2010' href='http://straightfromthea.com/2010/12/'/>
<link rel='archives' title='November 2010' href='http://straightfromthea.com/2010/11/'/>
<link rel='archives' title='October 2010' href='http://straightfromthea.com/2010/10/'/>
<link rel='archives' title='September 2010' href='http://straightfromthea.com/2010/09/'/>
<link rel='archives' title='August 2010' href='http://straightfromthea.com/2010/08/'/>
<link rel='archives' title='July 2010' href='http://straightfromthea.com/2010/07/'/>
<link rel='archives' title='June 2010' href='http://straightfromthea.com/2010/06/'/>
<link rel='archives' title='May 2010' href='http://straightfromthea.com/2010/05/'/>
<link rel='archives' title='April 2010' href='http://straightfromthea.com/2010/04/'/>
<link rel='archives' title='March 2010' href='http://straightfromthea.com/2010/03/'/>
<link rel='archives' title='February 2010' href='http://straightfromthea.com/2010/02/'/>
<link rel='archives' title='January 2010' href='http://straightfromthea.com/2010/01/'/>
<link rel='archives' title='December 2009' href='http://straightfromthea.com/2009/12/'/>
<link rel='archives' title='November 2009' href='http://straightfromthea.com/2009/11/'/>
<link rel='archives' title='October 2009' href='http://straightfromthea.com/2009/10/'/>
<link rel='archives' title='September 2009' href='http://straightfromthea.com/2009/09/'/>
<link rel='archives' title='August 2009' href='http://straightfromthea.com/2009/08/'/>
<link rel='archives' title='July 2009' href='http://straightfromthea.com/2009/07/'/>
<link rel='archives' title='June 2009' href='http://straightfromthea.com/2009/06/'/>
<link rel='archives' title='May 2009' href='http://straightfromthea.com/2009/05/'/>
<link rel='archives' title='April 2009' href='http://straightfromthea.com/2009/04/'/>
<link rel='archives' title='March 2009' href='http://straightfromthea.com/2009/03/'/>
<link rel='archives' title='February 2009' href='http://straightfromthea.com/2009/02/'/>
<link rel='archives' title='January 2009' href='http://straightfromthea.com/2009/01/'/>
<link rel='archives' title='December 2008' href='http://straightfromthea.com/2008/12/'/>
<link rel='archives' title='November 2008' href='http://straightfromthea.com/2008/11/'/>
<link rel='archives' title='October 2008' href='http://straightfromthea.com/2008/10/'/>
<link rel='archives' title='September 2008' href='http://straightfromthea.com/2008/09/'/>
<link rel='archives' title='August 2008' href='http://straightfromthea.com/2008/08/'/>
<link rel='archives' title='July 2008' href='http://straightfromthea.com/2008/07/'/>
<link rel='archives' title='June 2008' href='http://straightfromthea.com/2008/06/'/>
<link rel='archives' title='May 2008' href='http://straightfromthea.com/2008/05/'/>
<link rel='archives' title='April 2008' href='http://straightfromthea.com/2008/04/'/>
<link rel='archives' title='March 2008' href='http://straightfromthea.com/2008/03/'/>
<link rel='archives' title='February 2008' href='http://straightfromthea.com/2008/02/'/>
<link rel='archives' title='January 2008' href='http://straightfromthea.com/2008/01/'/>
<link rel='archives' title='December 2007' href='http://straightfromthea.com/2007/12/'/>
<link rel='archives' title='November 2007' href='http://straightfromthea.com/2007/11/'/>
<link rel='archives' title='October 2007' href='http://straightfromthea.com/2007/10/'/>
<link rel='archives' title='September 2007' href='http://straightfromthea.com/2007/09/'/>
<link rel='archives' title='August 2007' href='http://straightfromthea.com/2007/08/'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Feed" href="http://straightfromthea.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Comments Feed" href="http://straightfromthea.com/comments/feed/"/>
<meta name="description" content="It's BET Awards weekend and the parties have just begun! Last night, BET CEO Debra Lee hosted a star-studded gathering of who's who for her annual 'Pre-BET..."/>
<link rel="alternate" type="application/rss+xml" title="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News &raquo; Remy Ma, Giselle Bryant, Mona Scott Young &#038; More Attend Debra Lee&#8217;s Pre-BET Awards Dinner&#8230; (PHOTOS) Comments Feed" href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/feed/"/>
<meta name="keywords" content="BET Awards, Bryshere Gray, Debra lee, Estelle, French Montana, Giselle Bryant, Leslie Jones, Lil Mama, Love and Hip Hop Atlanta, Mona Scott Young, Remy Ma, Tamar Braxton, Tammy Rivera, Vincent Herbert, Yandy Smith"/>
<meta name="robots" content="index,follow,noodp,noydir"/>
<link rel="canonical" href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/"/>
 
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/straightfromthea.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false' src='//dsms0mj1bbhn4.cloudfront.net/assets/pub/shareaholic.js' data-shr-siteid='6138b4eb6e460dce4355a17f4f16ad8e' async='async'>
</script>
 
<meta name='shareaholic:site_name' content='Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News'/>
<meta name='shareaholic:language' content='en-US'/>
<meta name='shareaholic:url' content='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/'/>
<meta name='shareaholic:keywords' content='bet awards, bryshere gray, debra lee, estelle, french montana, giselle bryant, leslie jones, lil mama, love and hip hop atlanta, mona scott young, remy ma, tamar braxton, tammy rivera, vincent herbert, yandy smith, news'/>
<meta name='shareaholic:article_published_time' content='2017-06-23T00:49:14+00:00'/>
<meta name='shareaholic:article_modified_time' content='2017-06-23T00:52:35+00:00'/>
<meta name='shareaholic:shareable_page' content='true'/>
<meta name='shareaholic:article_author_name' content='ATLien'/>
<meta name='shareaholic:site_id' content='6138b4eb6e460dce4355a17f4f16ad8e'/>
<meta name='shareaholic:wp_version' content='7.8.0.6'/>
<meta name='shareaholic:image' content='http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2-520x689.jpg'/>
 
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/straightfromthea.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='sb_instagram_styles-css' href='http://straightfromthea.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.9' type='text/css' media='all'/>
<link rel='stylesheet' id='sb_instagram_icons-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-pagenavi-css' href='http://straightfromthea.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://straightfromthea.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all'/>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://straightfromthea.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://straightfromthea.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://straightfromthea.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)' href='http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/'/>
<meta name="generator" content="WordPress 4.7.5"/>
<link rel='shortlink' href='http://wp.me/p2F0SY-TZz'/>
<link rel="alternate" type="application/json+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2017%2F06%2F22%2Fremy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://straightfromthea.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstraightfromthea.com%2F2017%2F06%2F22%2Fremy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos%2F&#038;format=xml"/>
<script type="text/javascript">
	window._zem_rp_post_id = '215237';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'Remy+Ma%2C+Giselle+Bryant%2C+Mona+Scott+Young+%26+More+Attend+Debra+Lee%27s+Pre-BET+Awards+Dinner...+%28PHOTOS%29';
	window._zem_rp_post_tags = ['tammy+rivera', 'leslie+jones', 'bet+awards', 'vincent+herbert', 'lil+mama', 'bryshere+gray', 'yandy+smith', 'love+and+hip+hop+atlanta', 'debra+lee', 'mona+scott+young', 'estelle', 'remy+ma', 'french+montana', 'tamar+braxton', 'giselle+bryant', 'news', 'debra', 'remi', 'bryant', 'tamar', 'lee', 'lil', 'gisel', 'mona', 'yandi', 'estel', 'grai', 'braxton', 'alt', 'scott', 'app'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'http://straightfromthea.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '10';
</script>
<link rel="stylesheet" href="http://straightfromthea.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical-m.css?version=1.14"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important;}</style>
 
<script type="text/javascript">
if(document.location.protocol=='http:'){
 var Tynt=Tynt||[];Tynt.push('bVenCmai4r37sZadbiUt4I');
 (function(){var s=document.createElement('script');s.async="async";s.type="text/javascript";s.src='http://tcr.tynt.com/ti.js';var h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();
}
</script>
 
 
<meta property="og:type" content="article"/>
<meta property="og:title" content="Remy Ma, Giselle Bryant, Mona Scott Young &#038; More Attend Debra Lee&#8217;s Pre-BET Awards Dinner&#8230; (PHOTOS)"/>
<meta property="og:url" content="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/"/>
<meta property="og:description" content="It&#8217;s BET Awards weekend and the parties have just begun! Last night, BET CEO Debra Lee hosted a star-studded gathering of who&#8217;s who for her annual &#8216;Pre-BET Awards&#8217; dinner. G…"/>
<meta property="article:published_time" content="2017-06-23T00:49:14+00:00"/>
<meta property="article:modified_time" content="2017-06-23T00:49:18+00:00"/>
<meta property="og:site_name" content="Straight From The A [SFTA] - Atlanta Entertainment Industry Gossip &amp; News"/>
<meta property="og:image" content="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2.jpg"/>
<meta property="og:image:width" content="580"/>
<meta property="og:image:height" content="768"/>
<meta property="og:locale" content="en_US"/>
<meta name="twitter:site" content="@ATLien"/>
<meta name="twitter:image" content="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2.jpg?w=640"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:creator" content="@ATLien"/>
<script type='text/javascript' src="https://partner.googleadservices.com/gampad/google_service.js">
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-8098644933888050");
GS_googleEnableAllServices();
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Banner_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_HeaderCube_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_TopRight_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA-SkyScraper-HP-NEW1"); 
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Skyscraper_Homepage2");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_160x600_3_Homepage");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Cube_RightSidebar_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_300x250_1"); 
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_Below3rdPost_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_Below5thPost_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_FooterAd_728x90");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Header_Banner_728x90");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Header_Cube_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_CUBE_TOP_Right_300x250");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_RightSidebar_ROS1");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Sidebar_Middle_160x600");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Sidebar_3_160x600");
GA_googleAddSlot("ca-pub-8098644933888050", "SFTA_Cube_BelowThePost");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
<style>a.sociallink{color:#fff;}a.sociallink:hover{color:#fc0;}.followme{color:#fc0;font-weight:bold;padding:0 .5em 0 0;}</style>
<script src='https://use.fontawesome.com/804c885ca3.js'></script>
</head>
<body class="post-template-default single single-post postid-215237 single-format-standard">
<div id="container"> 
<div class="top-wrapper"><div class="top"></div></div>
<header class="site-header">
<h1 class="title"><a href="http://straightfromthea.com/" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!" class="identity"><img class="logo" src="http://straightfromthea.com/wp-content/uploads/2015/04/sftalogo31.png" alt="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News - Atlanta&#039;s Most Reliable Source of Entertainment Gossip!"/></a></h1>
<div class="searcharea-wrapper">
<form action="https://www.google.com/cse" class="cse-search-box" id="cse-search-box" target="_blank"><input type="hidden" name="cx" value="partner-pub-8098644933888050:4muutu6gym3"/><input type="hidden" name="ie" value="UTF-8"/><input type="text" name="q" size="31" class="txt"/><input type="submit" name="sa" class="btn submit" value="Search"/></form><script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
<div class="socialbuttons-wrapper">
<span class="followme">Get Social: </span>
<a class="sociallink" href="http://straightfromthea.com/feed/" title="Straight From The A Feed">
<i class="fa fa-rss fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://www.youtube.com/channel/UCcYwBgVSgvU1J830VqOInXQ" title="ATLien on YouTube">
<i class="fa fa-youtube fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://twitter.com/atlien" title="ATLien On Twitter">
<i class="fa fa-twitter fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://facebook.com/StraightFromTheA" title="Straight From The A on Facebook">
<i class="fa fa-facebook fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://instagram.com/iamatlien" title="ATLien on Instagram">
<i class="fa fa-instagram fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://snapchat.com/add/iamatlien" title="ATLien on Snapchat">
<i class="fa fa-snapchat fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="https://periscope.tv/atlien" title="ATLien on Periscope">
<i class="fa fa-circle fa-lg" aria-hidden="true"></i>
</a>
<a class="sociallink" href="http://iamatlien.com" title="ATLien on Tumblr">
<i class="fa fa-tumblr fa-lg" aria-hidden="true"></i>
</a>
</div> 
</div>
</header>
<center> 
 
<script type='text/javascript'>
GA_googleFillSlot("SFTA_Header_Banner_728x90");
</script>
 </center>
<nav class="top-navigation-wrapper"><div class="primary-navigation-menu"><ul id="menu-primary" class="menu"><li id="menu-item-176006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-176006"><a title="Home" href="http://straightfromthea.com/">Home</a></li>
<li id="menu-item-198946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-198946"><a href="http://straightfromthea.com/gallery">Photos</a></li>
<li id="menu-item-213388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-213388"><a href="http://straightfromthea.com/videos/">Videos</a></li>
<li id="menu-item-176009" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176009"><a title="Archives" href="http://straightfromthea.com/archives/">Archives</a></li>
<li id="menu-item-176008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176008"><a title="Advertise" href="http://straightfromthea.com/advertise/">Advertise</a></li>
<li id="menu-item-176012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176012"><a title="About" href="http://straightfromthea.com/about/">About</a></li>
<li id="menu-item-176011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176011"><a title="Contact" href="http://straightfromthea.com/contact/">Contact</a></li>
<li id="menu-item-176007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176007"><a title="DMCA" href="http://straightfromthea.com/dmca/">DMCA</a></li>
</ul></div></nav>
<br/>
<div class="featured-wrapper">
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/" rel="bookmark" title="Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-300x298.png 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-768x763.png 768w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-520x517.png 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-144x144.png 144w, http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1.png 773w" sizes="(max-width: 190px) 100vw, 190px"/><img src="http://straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1-520x517.png" alt="Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)" class="catchthatimg" style="width:190px;height:190px;"/>
</a>
</div>
<h4><a href="http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/" rel="bookmark" title="Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)">Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/" rel="bookmark" title="What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-300x302.png 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-520x523.png 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-144x144.png 144w, http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017.png 764w" sizes="(max-width: 190px) 100vw, 190px"/><img src="http://straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017-520x523.png" alt="What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)" class="catchthatimg" style="width:190px;height:190px;"/>
</a>
</div>
<h4><a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/" rel="bookmark" title="What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)">What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)</a></h4>
</div>
<div class="featuredpost">
<div class="image-wrapper">
<a href="http://straightfromthea.com/2017/06/20/are-t-i-tiny-reconciling-matching-outfits-late-night-booty-calls-could-be-clues-photos/" rel="bookmark" title="Are T.I. &#038; Tiny Reconciling? Matching Outfits &#038; Late Night Booty Calls Could Be Clues&#8230; (PHOTOS)">
<img width="190" height="190" src="http://straightfromthea.com/wp-content/uploads/2017/06/TI-TIny-2017-2-190x190.png" class="attachment-190x190 size-190x190 wp-post-image" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/TI-TIny-2017-2-190x190.png 190w, http://straightfromthea.com/wp-content/uploads/2017/06/TI-TIny-2017-2-150x150.png 150w, http://straightfromthea.com/wp-content/uploads/2017/06/TI-TIny-2017-2-144x144.png 144w" sizes="(max-width: 190px) 100vw, 190px"/><img src="http://straightfromthea.com/wp-content/uploads/2017/06/T.I.-and-Tiny-2017-1-520x647.png" alt="Are T.I. &#038; Tiny Reconciling? Matching Outfits &#038; Late Night Booty Calls Could Be Clues&#8230; (PHOTOS)" class="catchthatimg" style="width:190px;height:190px;"/>
</a>
</div>
<h4><a href="http://straightfromthea.com/2017/06/20/are-t-i-tiny-reconciling-matching-outfits-late-night-booty-calls-could-be-clues-photos/" rel="bookmark" title="Are T.I. &#038; Tiny Reconciling? Matching Outfits &#038; Late Night Booty Calls Could Be Clues&#8230; (PHOTOS)">Are T.I. &#038; Tiny Reconciling? Matching Outfits &#038; Late Night Booty Calls Could Be Clues&#8230; (PHOTOS)</a></h4>
</div>
<div class="featuredad">
<br>
<center><script type='text/javascript'>GA_googleFillSlot("SFTA_Header_Cube_300x250");</script></center>
</div>
<div class="clear"></div>
</div> <ul id="main"> 
<li id="content"> 
<div class="post-215237 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-bet-awards tag-bryshere-gray tag-debra-lee tag-estelle tag-french-montana tag-giselle-bryant tag-leslie-jones tag-lil-mama tag-love-and-hip-hop-atlanta tag-mona-scott-young tag-remy-ma tag-tamar-braxton tag-tammy-rivera tag-vincent-herbert tag-yandy-smith" id="post-215237"> 
<div class='shareaholic-canvas' data-app-id='14600962' data-app='share_buttons' data-title='Remy Ma, Giselle Bryant, Mona Scott Young &amp; More Attend Debra Lee&#039;s Pre-BET Awards Dinner... (PHOTOS)' data-link='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/' data-summary=''></div><h1 class="storytitle"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/" rel="bookmark">Remy Ma, Giselle Bryant, Mona Scott Young &#038; More Attend Debra Lee&#8217;s Pre-BET Awards Dinner&#8230; (PHOTOS)</a></h1>
<div class="meta"> 
Jun, 22 2017 | Written by ATLien </div> 
<div class="storycontent"> 
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma-debra-lee/" rel="attachment wp-att-215265"><img class="alignnone size-full wp-image-215265" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee.jpg" alt="" width="499" height="768" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee.jpg 499w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-300x462.jpg 300w" sizes="(max-width: 499px) 100vw, 499px"/></a></p>
<p>It&#8217;s BET Awards weekend and the parties have just begun!</p>
<p>Last night, BET CEO Debra Lee hosted a star-studded gathering of who&#8217;s who for her annual &#8216;Pre-BET Awards&#8217; dinner.</p>
<p>Guests included: Leslie Jones, Tamar Braxton, Vincent Herbert, Bryshere Gray, Mona Scott Young, Yandy Smith , Lil Mama, French Montana, Remy Ma, Estelle, Tammy Rivera, Jackie Long, Giselle Bryant and many more.</p>
<p>Photos below&#8230;<span id="more-215237"></span></p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7707/" rel="attachment wp-att-215338"><img class="alignnone size-large wp-image-215338" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-520x673.jpg" alt="" width="520" height="673" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-520x673.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-300x389.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707.jpg 593w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Leslie Jones &#8211; Host of the 2017 BET Awards</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8244/" rel="attachment wp-att-215293"><img class="alignnone size-large wp-image-215293" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-520x659.jpg" alt="" width="520" height="659" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-520x659.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-300x380.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244.jpg 606w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Tamar Braxton arrives&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/vince-herbert-2/" rel="attachment wp-att-215259"><img class="alignnone size-large wp-image-215259" src="http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-520x511.jpg" alt="" width="520" height="511" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-520x511.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-300x295.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-768x754.jpg 768w, http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert.jpg 782w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Vince Herbert&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/mona-scott-young-1/" rel="attachment wp-att-215245"><img class="alignnone size-full wp-image-215245" src="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1.jpg" alt="" width="512" height="768" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1.jpg 512w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1-300x450.jpg 300w" sizes="(max-width: 512px) 100vw, 512px"/></a></p>
<p style="text-align: center;">Mona Scott Young Arrives&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/lil-mama-3-2/" rel="attachment wp-att-215313"><img class="alignnone size-large wp-image-215313" src="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-520x740.jpg" alt="" width="520" height="740" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-520x740.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-300x427.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3.jpg 540w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Lil Mama serving &#8216;face&#8217;&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8491/" rel="attachment wp-att-215238"><img class="alignnone size-large wp-image-215238" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-520x540.jpg" alt="" width="520" height="540" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-520x540.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-300x312.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491.jpg 739w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Bryshere Gray (Empire) smiles for the ET cameras&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9185/" rel="attachment wp-att-215273"><img class="alignnone size-large wp-image-215273" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-520x328.jpg" alt="" width="520" height="328" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-520x328.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-300x189.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-768x484.jpg 768w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185.jpg 1024w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">DJ D-Nice on the 1&#8217;s and 2&#8217;s&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9117/" rel="attachment wp-att-215268"><img class="alignnone size-large wp-image-215268" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-520x378.jpg" alt="" width="520" height="378" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-520x378.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-300x218.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-768x558.jpg 768w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117.jpg 1024w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Manny Halley poses with Tammy Rivera (Love &amp; Hip Hop Atlanta) &amp; Actor Jackie Long&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8619/" rel="attachment wp-att-215241"><img class="alignnone size-large wp-image-215241" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-520x730.jpg" alt="" width="520" height="730" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-520x730.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-300x421.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619.jpg 547w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Yandy Smith (Love &amp; Hip Hop NYC) Arrives&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/papoose-remy-ma-2/" rel="attachment wp-att-215264"><img class="alignnone size-large wp-image-215264" src="http://straightfromthea.com/wp-content/uploads/2017/06/Papoose-Remy-Ma-2-520x506.jpg" alt="" width="520" height="506" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Papoose-Remy-Ma-2-520x506.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Papoose-Remy-Ma-2-300x292.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Papoose-Remy-Ma-2-768x748.jpg 768w, http://straightfromthea.com/wp-content/uploads/2017/06/Papoose-Remy-Ma-2.jpg 789w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Papoose and Remy Ma&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/french-montana-3/" rel="attachment wp-att-215263"><img class="alignnone size-large wp-image-215263" src="http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-520x693.jpg" alt="" width="520" height="693" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-520x693.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-300x400.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana.jpg 576w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">French Montana&#8230;</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/estelle-3-2/" rel="attachment wp-att-215296"><img class="alignnone size-large wp-image-215296" src="http://straightfromthea.com/wp-content/uploads/2017/06/Estelle-3-520x711.jpg" alt="" width="520" height="711" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Estelle-3-520x711.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/Estelle-3-300x410.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/Estelle-3.jpg 562w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Estelle</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7868/" rel="attachment wp-att-215322"><img class="alignnone size-full wp-image-215322" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868.jpg" alt="" width="512" height="768" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868.jpg 512w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868-300x450.jpg 300w" sizes="(max-width: 512px) 100vw, 512px"/></a></p>
<p style="text-align: center;">Giselle (Real Housewives of Potomac)</p>
<p style="text-align: center;"><a href="http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9059/" rel="attachment wp-att-215266"><img class="alignnone size-large wp-image-215266" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-520x606.jpg" alt="" width="520" height="606" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-520x606.jpg 520w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-300x350.jpg 300w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059.jpg 659w" sizes="(max-width: 520px) 100vw, 520px"/></a></p>
<p style="text-align: center;">Erica Ashe, Remy Ma, Debra Lee, Wendy Rachel Robinson&#8230;</p>
<style type='text/css'>#gallery-1{margin:auto;}#gallery-1 .gallery-item{float:left;margin-top:10px;text-align:center;width:33%;}#gallery-1 img{border:2px solid #cfcfcf;}#gallery-1 .gallery-caption{margin-left:0;}</style>
<div id='gallery-1' class='gallery galleryid-215237 gallery-columns-3 gallery-size-thumbnail'><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7707/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7707-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7705/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7705-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7705-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7705-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7705-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7772/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7772-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7772-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7772-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7772-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7778/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7778-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7778-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7778-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7778-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7788/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7788-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7788-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7788-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7788-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7724/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7724-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7724-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7724-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7724-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7841/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7841-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7841-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7841-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7841-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7818/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7818-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7818-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7818-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7818-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7872/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7872-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7872-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7872-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7872-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7868/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7868-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7891-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7891-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7891-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7891-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7891-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7896/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7896-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7896-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7896-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7896-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7927/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7927-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7927-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7927-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7927-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_7924/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7924-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7924-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7924-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_7924-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/lil-mama-8/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/lil-mama-2-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-2-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-2-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-2-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-Mama-2-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/lil-mama-4/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-4-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-4-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-4-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-4-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/lil-mama-3-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Lil-mama-3-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/tammy-rivera-1-5/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-1-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-1-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-1-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-1-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/tammy-rivera-2-4/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-2-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-2-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-2-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-2-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/tammy-rivera-4-4/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-4-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-4-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-4-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Tammy-Rivera-4-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/debra-lee-3/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Debra-Lee-3-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Debra-Lee-3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Debra-Lee-3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Debra-Lee-3-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma-debra-lee-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-2-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma-debra-lee/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-Debra-Lee-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9059/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9059-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon landscape'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9117/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9117-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9100/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9100-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9100-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9100-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9100-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/french-montana-3/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/French-Montana-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon landscape'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/vince-herbert-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Vince-Herbert-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8244/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8244-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/mona-scott-young-3-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-3-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-3-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/mona-scott-young-1/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young-1-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/mona-scott-young-4/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young--150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young--150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young--190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Mona-Scott-Young--144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8628/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8628-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8628-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8628-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8628-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8624-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8624-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8624-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8624-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8624-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8619/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8619-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8491/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8491-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8784/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8784-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8784-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8784-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8784-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/kim-whitley/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Kim-Whitley-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Kim-Whitley-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Kim-Whitley-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Kim-Whitley-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma-3/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-3-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-3-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-3-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-3-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/remy-ma-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-2-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-2-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-2-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/Remy-Ma-2-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9132/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9132-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9132-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9132-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9132-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon landscape'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9145/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9145-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9145-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9145-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9145-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon landscape'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9185/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9185-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8469/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8469-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8469-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8469-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8469-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_9231/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9231-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9231-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9231-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_9231-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><dl class='gallery-item'>
<dt class='gallery-icon portrait'>
<a href='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/dsc_8344-2/'><img width="150" height="150" src="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8344-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" srcset="http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8344-150x150.jpg 150w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8344-190x190.jpg 190w, http://straightfromthea.com/wp-content/uploads/2017/06/DSC_8344-144x144.jpg 144w" sizes="(max-width: 150px) 100vw, 150px"/></a>
</dt></dl><br style="clear: both"/>
</div>
<p style="text-align: center;">Photos: Prince Williams (<a href="http://ATLPics.net" target="_blank" rel="noopener noreferrer">ATLPics</a>)</p>
<div class="zem_rp_wrap zem_rp_th_vertical_m" id="zem_rp_first"><div class="zem_rp_content"><h3 class="related_post_title">Related Posts</h3><ul class="related_post zem_rp"><li data-position="0" data-poid="in-181707" data-post-type="none"><a href="http://straightfromthea.com/2015/08/04/bood-up-lhhatl-tammy-rivera-celebrates-birthday-wwaka-flocka-flame-scrappy-bambi-more-photos/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2015/08/Waka-and-Tammy-01-150x150.jpg" alt="Boo&#8217;d Up: #LHHATL Tammy Rivera Celebrates Birthday w/Waka Flocka Flame, Scrappy, Bambi &#038; More&#8230; [PHOTOS]" width="150" height="150"/></a><a href="http://straightfromthea.com/2015/08/04/bood-up-lhhatl-tammy-rivera-celebrates-birthday-wwaka-flocka-flame-scrappy-bambi-more-photos/" class="zem_rp_title">Boo&#8217;d Up: #LHHATL Tammy Rivera Celebrates Birthday w/Waka Flocka Flame, Scrappy, Bambi &#038; More&#8230; [PHOTOS]</a></li><li data-position="1" data-poid="in-184172" data-post-type="none"><a href="http://straightfromthea.com/2015/09/25/club-shots-angela-simmons-yung-joc-tammy-rivera-bambi-party-at-the-gold-room-photos/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2015/09/PAW_3112-150x150.jpg" alt="Club Shots: Angela Simmons, Yung Joc, Tammy Rivera &#038; Bambi Party At The Gold Room&#8230; [PHOTOS]" width="150" height="150"/></a><a href="http://straightfromthea.com/2015/09/25/club-shots-angela-simmons-yung-joc-tammy-rivera-bambi-party-at-the-gold-room-photos/" class="zem_rp_title">Club Shots: Angela Simmons, Yung Joc, Tammy Rivera &#038; Bambi Party At The Gold Room&#8230; [PHOTOS]</a></li><li data-position="2" data-poid="in-178162" data-post-type="none"><a href="http://straightfromthea.com/2015/05/27/icymi-love-and-hip-hop-the-wedding-photos-full-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2015/05/LHHWedding-2-150x150.jpg" alt="ICYMI: Love and Hip Hop: The Wedding&#8230; [PHOTOS + FULL VIDEO]" width="150" height="150"/></a><a href="http://straightfromthea.com/2015/05/27/icymi-love-and-hip-hop-the-wedding-photos-full-video/" class="zem_rp_title">ICYMI: Love and Hip Hop: The Wedding&#8230; [PHOTOS + FULL VIDEO]</a></li><li data-position="3" data-poid="in-161460" data-post-type="none"><a href="http://straightfromthea.com/2015/01/16/fan-mail-the-real-creator-of-sorority-sisters-is-an-aka/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2015/01/Shanta-Mayes-Sorority-Sisters-150x150.jpg" alt="They Say: The REAL Creator of #SororitySisters Is An AKA&#8230; [EXCLUSIVE PHOTOS]" width="150" height="150"/></a><a href="http://straightfromthea.com/2015/01/16/fan-mail-the-real-creator-of-sorority-sisters-is-an-aka/" class="zem_rp_title">They Say: The REAL Creator of #SororitySisters Is An AKA&#8230; [EXCLUSIVE PHOTOS]</a></li><li data-position="4" data-poid="in-156338" data-post-type="none"><a href="http://straightfromthea.com/2014/11/21/stevie-j-claims-benzino-was-fired-for-making-death-threats-benzino-responds-w-lawsuit-threat/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2014/11/Benzino-Stevie-J-StraightFroMTheA-150x150.png" alt="Stevie J. Claims Benzino Was Fired For Making Death Threats + Benzino Responds w/ Lawsuit Threat&#8230;" width="150" height="150"/></a><a href="http://straightfromthea.com/2014/11/21/stevie-j-claims-benzino-was-fired-for-making-death-threats-benzino-responds-w-lawsuit-threat/" class="zem_rp_title">Stevie J. Claims Benzino Was Fired For Making Death Threats + Benzino Responds w/ Lawsuit Threat&#8230;</a></li><li data-position="5" data-poid="in-198513" data-post-type="none"><a href="http://straightfromthea.com/2016/06/28/entire-cast-of-love-hip-hop-atlanta-fired-watch-season-5-episode-12-lovers-or-friends-full-video/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2016/06/3-150x150.jpg" alt="Entire Cast of Love &#038; Hip Hop: ATLANTA Fired!? + Watch Season 5 Episode 12: &#8220;Lovers or Friends?&#8221; [FULL VIDEO]" width="150" height="150"/></a><a href="http://straightfromthea.com/2016/06/28/entire-cast-of-love-hip-hop-atlanta-fired-watch-season-5-episode-12-lovers-or-friends-full-video/" class="zem_rp_title">Entire Cast of Love &#038; Hip Hop: ATLANTA Fired!? + Watch Season 5 Episode 12: &#8220;Lovers or Friends?&#8221; [FULL VIDEO]</a></li><li data-position="6" data-poid="in-125329" data-post-type="none"><a href="http://straightfromthea.com/2013/06/17/tamar-braxton-1st-photo-new-baby-fathers-day/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2013/06/tamar-braxton-baby-150x150.png" alt="Tamar Braxton Shares 1st Photo of Baby &#8216;Logan Vincent Herbert&#8217; + Sends Special Father&#8217;s Day Message&#8230;[PHOTOS]" width="150" height="150"/></a><a href="http://straightfromthea.com/2013/06/17/tamar-braxton-1st-photo-new-baby-fathers-day/" class="zem_rp_title">Tamar Braxton Shares 1st Photo of Baby &#8216;Logan Vincent Herbert&#8217; + Sends Special Father&#8217;s Day Message&#8230;[PHOTOS]</a></li><li data-position="7" data-poid="in-127874" data-post-type="none"><a href="http://straightfromthea.com/2013/07/31/tamar-braxton-baby-logan-good-morning-america/" class="zem_rp_thumbnail"><img width="150" height="98" src="http://straightfromthea.com/wp-content/uploads/2013/07/tamar-tweet-150x98.png" class="attachment-150x150 size-150x150 wp-post-image" alt=""/></a><a href="http://straightfromthea.com/2013/07/31/tamar-braxton-baby-logan-good-morning-america/" class="zem_rp_title">Tamar Braxton Finally Reveals Photos of Baby Logan Vincent Herbert + Discusses Attachment Issues on GMA [VIDEO]</a></li><li data-position="8" data-poid="in-122640" data-post-type="none"><a href="http://straightfromthea.com/2013/05/06/tamar-braxton-backyard-boogie-baby-shower-photos/" class="zem_rp_thumbnail"><img src="http://straightfromthea.com/wp-content/uploads/2013/05/Tamar-Braxton-Baby-Shower-050513-6-150x150.jpg" alt="Tamar &#038; Vince Host &#8216;Backyard Boogie&#8217; Baby Shower&#8230; [PHOTOS]" width="150" height="150"/></a><a href="http://straightfromthea.com/2013/05/06/tamar-braxton-backyard-boogie-baby-shower-photos/" class="zem_rp_title">Tamar &#038; Vince Host &#8216;Backyard Boogie&#8217; Baby Shower&#8230; [PHOTOS]</a></li><li data-position="9" data-poid="in-124690" data-post-type="none"><a href="http://straightfromthea.com/2013/06/07/tamar-braxton-give-birth-baby-boy-photos/" class="zem_rp_thumbnail"><img width="150" height="83" src="http://straightfromthea.com/wp-content/uploads/2013/06/Screen-Shot-2013-06-07-at-12.20.03-PM-150x83.png" class="attachment-150x150 size-150x150 wp-post-image" alt=""/></a><a href="http://straightfromthea.com/2013/06/07/tamar-braxton-give-birth-baby-boy-photos/" class="zem_rp_title">It&#8217;s a BOY! Tamar Braxton &#038; Vince Herbert Welcome a Son! [PHOTOS]</a></li></ul></div></div>
<div class='shareaholic-canvas' data-app-id='14600957' data-app='share_buttons' data-title='Remy Ma, Giselle Bryant, Mona Scott Young &amp; More Attend Debra Lee&#039;s Pre-BET Awards Dinner... (PHOTOS)' data-link='http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/' data-summary=''></div>
<div class="pagination-wrapper">
</div>
</div> 
<div style="font-size:10px;"><em> In <a href="http://straightfromthea.com/category/news/" rel="category tag">News</a> <a href="http://straightfromthea.com/tag/bet-awards/" rel="tag">BET Awards</a>, <a href="http://straightfromthea.com/tag/bryshere-gray/" rel="tag">Bryshere Gray</a>, <a href="http://straightfromthea.com/tag/debra-lee/" rel="tag">Debra lee</a>, <a href="http://straightfromthea.com/tag/estelle/" rel="tag">Estelle</a>, <a href="http://straightfromthea.com/tag/french-montana/" rel="tag">French Montana</a>, <a href="http://straightfromthea.com/tag/giselle-bryant/" rel="tag">Giselle Bryant</a>, <a href="http://straightfromthea.com/tag/leslie-jones/" rel="tag">Leslie Jones</a>, <a href="http://straightfromthea.com/tag/lil-mama/" rel="tag">Lil Mama</a>, <a href="http://straightfromthea.com/tag/love-and-hip-hop-atlanta/" rel="tag">Love and Hip Hop Atlanta</a>, <a href="http://straightfromthea.com/tag/mona-scott-young/" rel="tag">Mona Scott Young</a>, <a href="http://straightfromthea.com/tag/remy-ma/" rel="tag">Remy Ma</a>, <a href="http://straightfromthea.com/tag/tamar-braxton/" rel="tag">Tamar Braxton</a>, <a href="http://straightfromthea.com/tag/tammy-rivera/" rel="tag">Tammy Rivera</a>, <a href="http://straightfromthea.com/tag/vincent-herbert/" rel="tag">Vincent Herbert</a>, <a href="http://straightfromthea.com/tag/yandy-smith/" rel="tag">Yandy Smith</a></em></div>
<div class="feedback"> 
</div> 
</div> 
<div class="adspot">
<center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8098644933888050" data-ad-slot="9114578170"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
<div class="comments" id="comments">
<div id="disqus_thread">
</div>
<script type="text/javascript">
var disqus_url = 'http://straightfromthea.com/2017/06/22/remy-ma-giselle-bryant-mona-scott-young-more-attend-debra-lees-pre-bet-awards-dinner-photos/';
var disqus_identifier = '215237 http://straightfromthea.com/?p=215237';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'straightfromthea';
var disqus_title = "Remy Ma, Giselle Bryant, Mona Scott Young &#038; More Attend Debra Lee&#8217;s Pre-BET Awards Dinner&#8230; (PHOTOS)";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</div>
<div class="navigation">
<div class="alignleft"></div>
<div class="alignright"></div>
</div>
</li> 
<li id="sidebar"> 
<ul>
<center> 
<script type='text/javascript'>
GA_googleFillSlot("SFTA_CUBE_TOP_Right_300x250");
</script></center>
<li id="adspot"> 
<ul class="sidebar"> 
<li id="text-459501718" class="widget widget_text"><h2>Subscribe</h2> <div class="textwidget"><center><form class="feedburner-wrapper" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=sfta', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Enter email address to receive StraightFromTheA.com updates in your inbox:</p>
<p>Enter your email address:</p>
<p><input class="txt type="text" name="email"/>
<input type="hidden" value="sfta" name="uri"/>
<input type="hidden" name="loc" value="en_US"/>
<input class="btn" type="submit" value="Subscribe" />
</form></p></center></div>
		</li><li id="text-459501728" class="widget widget_text"><h2>Like Us on Facebook</h2>			<div class="textwidget"><center><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FStraightFromTheA%2F&tabs&width=340&height=214&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId=527308440666890" width="340" height="214" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></center></div>
		</li></ul><!-- ends sidebar -->
</li><!-- ends adspot -->

<li id="left"><!-- starts right -->
<ul class="sidebar"><!-- starts sidebar -->
<li id="top-posts-6" class="widget widget_top-posts"><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="http://straightfromthea.com/2017/06/22/southern-university-queen-involved-in-sex-tape-scandal-photos/" title="Former Southern University Queen Involved in Sex Tape Scandal... (PHOTOS)" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i2.wp.com/straightfromthea.com/wp-content/uploads/2017/06/dumas.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Former Southern University Queen Involved in Sex Tape Scandal... (PHOTOS)" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://straightfromthea.com/2017/06/22/southern-university-queen-involved-in-sex-tape-scandal-photos/" class="bump-view" data-bump-view="tp">
								Former Southern University Queen Involved in Sex Tape Scandal... (PHOTOS)							</a>
						</div>
											</li>
									<li>
												<a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/" title="What&#039;s Beef! Porsha Williams Shades Nene Leakes&#039; Season 10 #RHOA Return... (VIDEO)" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i1.wp.com/straightfromthea.com/wp-content/uploads/2017/06/Porsha-vs.-Nene-2017.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="What&#039;s Beef! Porsha Williams Shades Nene Leakes&#039; Season 10 #RHOA Return... (VIDEO)" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/" class="bump-view" data-bump-view="tp">
								What&#039;s Beef! Porsha Williams Shades Nene Leakes&#039; Season 10 #RHOA Return... (VIDEO)							</a>
						</div>
											</li>
									<li>
												<a href="http://straightfromthea.com/2017/06/20/are-t-i-tiny-reconciling-matching-outfits-late-night-booty-calls-could-be-clues-photos/" title="Are T.I. &amp; Tiny Reconciling? Matching Outfits &amp; Late Night Booty Calls Could Be Clues... (PHOTOS)" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i0.wp.com/straightfromthea.com/wp-content/uploads/2017/06/TI-TIny-2017-2.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Are T.I. &amp; Tiny Reconciling? Matching Outfits &amp; Late Night Booty Calls Could Be Clues... (PHOTOS)" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://straightfromthea.com/2017/06/20/are-t-i-tiny-reconciling-matching-outfits-late-night-booty-calls-could-be-clues-photos/" class="bump-view" data-bump-view="tp">
								Are T.I. &amp; Tiny Reconciling? Matching Outfits &amp; Late Night Booty Calls Could Be Clues... (PHOTOS)							</a>
						</div>
											</li>
									<li>
												<a href="http://straightfromthea.com/2017/06/20/if-you-care-rhoa-kenya-moores-husband-revealed-photos/" title="If You Care: #RHOA Kenya Moore&#039;s &#039;Husband&#039; Revealed... (PHOTOS)" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i0.wp.com/straightfromthea.com/wp-content/uploads/2017/06/Kenya-Moore-Wedding-2017-2-1.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="If You Care: #RHOA Kenya Moore&#039;s &#039;Husband&#039; Revealed... (PHOTOS)" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://straightfromthea.com/2017/06/20/if-you-care-rhoa-kenya-moores-husband-revealed-photos/" class="bump-view" data-bump-view="tp">
								If You Care: #RHOA Kenya Moore&#039;s &#039;Husband&#039; Revealed... (PHOTOS)							</a>
						</div>
											</li>
									<li>
												<a href="http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/" title="Pic of the Day! Kim Porter &amp; Sarah Chapman Support Diddy&#039;s &#039;Can&#039;t Stop Won&#039;t Stop&#039; Screening... (PHOTOS)" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i1.wp.com/straightfromthea.com/wp-content/uploads/2017/06/Diddy-Kim-Porter-Sarah-Chapman-Girls-1.png?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Pic of the Day! Kim Porter &amp; Sarah Chapman Support Diddy&#039;s &#039;Can&#039;t Stop Won&#039;t Stop&#039; Screening... (PHOTOS)" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/" class="bump-view" data-bump-view="tp">
								Pic of the Day! Kim Porter &amp; Sarah Chapman Support Diddy&#039;s &#039;Can&#039;t Stop Won&#039;t Stop&#039; Screening... (PHOTOS)							</a>
						</div>
											</li>
				</ul>
</li><li id="recent-comments-4" class="widget widget_recent_comments"><h2>Who&#8217;s Talking?</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/1204319506266901" rel='external nofollow' class='url'>Avis Graham</a></span> on <a href="http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/#comment-5512195">Pic of the Day! Kim Porter &#038; Sarah Chapman Support Diddy&#8217;s &#8216;Can&#8217;t Stop Won&#8217;t Stop&#8217; Screening&#8230; (PHOTOS)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/1210580888964936" rel='external nofollow' class='url'>Alan Taylor</a></span> on <a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/#comment-5512192">What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/10209613641481762" rel='external nofollow' class='url'>Mia Mccamey</a></span> on <a href="http://straightfromthea.com/2017/06/22/southern-university-queen-involved-in-sex-tape-scandal-photos/#comment-5512188">Former Southern University Queen Involved in Sex Tape Scandal&#8230; (PHOTOS)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/1093375064018477" rel='external nofollow' class='url'>TamEcia Lovnmesomehim Brown</a></span> on <a href="http://straightfromthea.com/2017/06/22/southern-university-queen-involved-in-sex-tape-scandal-photos/#comment-5512189">Former Southern University Queen Involved in Sex Tape Scandal&#8230; (PHOTOS)</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://www.facebook.com/1382167578469764" rel='external nofollow' class='url'>Daryl Beale</a></span> on <a href="http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/#comment-5512193">What&#8217;s Beef! Porsha Williams Shades Nene Leakes&#8217; Season 10 #RHOA Return&#8230; (VIDEO)</a></li></ul></li></ul><!-- ends sidebar -->
</li><!-- ends left -->

<li id="right"><!-- starts right -->
<ul class="sidebar"><!-- starts sidebar -->
<center>
<br></br><!-- begin ad tag --><!-- SFTA_RightSidebar_ROS1 -->
<script type='text/javascript'>
GA_googleFillSlot("SFTA_RightSidebar_ROS1");
</script>
<!-- end ad tag -->
<br></br>
<!-- begin ad tag --><!-- SFTA_Sidebar_Middle_160x600 -->
<script type='text/javascript'>
GA_googleFillSlot("SFTA_Sidebar_Middle_160x600");
</script>
<!-- end ad tag -->
</br>
<!-- begin ad tag --><!-- SFTA_Sidebar_3_160x600 -->
<script type='text/javascript'>
GA_googleFillSlot("SFTA_Sidebar_3_160x600");
</script>
<!-- end ad tag -->
</center>
</ul><!-- ends sidebar -->
</li><!-- ends right -->
<li class="clear">&nbsp;</li>
<li id="belowadspot"><!-- starts belowadspot -->
<ul class="sidebar"><!-- starts sidebar -->
<li id="text-459501717" class="widget widget_text"><h2>Social Networks</h2>			<div class="textwidget"><div style="display:block;margin:0 auto;text-align:center"><a title="ATLien's Tumblr (Personal Site)" href="http://iamATLien.com" target="_blank"><img title="iamATLien.com" alt="iamATLien.com" src="http://straightfromthea.com/wp-content/uploads/2012/06/fullscreen_capture_582011_123314_am.bmp-300x110.jpg"/></a></div>
</div>
		</li><li id="text-459501724" class="widget widget_text"><h2>Instagram</h2>			<div class="textwidget"><div id="sb_instagram" class="sbi sbi_fixed_height  sbi_col_4" style="width:340px; height:340px; background-color: #0a0400; padding-bottom: 4px; " data-id="3061145" data-num="8" data-res="auto" data-cols="4" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;headercolor&quot;: &quot;&quot;, &quot;imagepadding&quot;: &quot;2&quot;}'><div class="sb_instagram_header" style="padding: 4px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 2px;"><div class="sbi_loader fa-spin"></div></div><div id="sbi_load"><a class="sbi_load_btn" href="javascript:void(0);" style="">Load More...</a><div class="sbi_follow_btn"><a href="https://instagram.com/" style="" target="_blank"><i class="fa fa-instagram"></i>Follow on Instagram</a></div></div></div></div>
		</li><li id="text-459501727" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-8098644933888050"
     data-ad-slot="6822768972"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</li><li id="text-459501725" class="widget widget_text"><h2>ATLien for Dramatic Weight Loss</h2>			<div class="textwidget"><center><a href="http://straightfromthea.com/wp-content/uploads/2010/12/SFTA-DWL-coupon.pdf" target="_blank" rel="attachment wp-att-67225"><img class="size-medium wp-image-67225 aligncenter" src="http://straightfromthea.com/wp-content/uploads/2011/08/Slide16-300x205.jpg" alt="DWL ATLien Michelle Brown Dramatic Weight Loss" width="300" height="205" /></a></center>
<center>READ: <a href="http://straightfromthea.com/2011/09/20/atlien-dramatic-weight-loss-at-fso20/" target="_blank">My Ode to Dramatic Weight Loss (PHOTOS)</a></center>
<center>**StraightFromTheA.com readers receive special discount:</center>
<center><a href="http://straightfromthea.com/wp-content/uploads/2010/12/SFTA-DWL-coupon.pdfil-dramatic-weight-loss/">CLICK HERE</a> for Discount Coupon!</center>
<br></br>
<center><script src="//ap.lijit.com/www/delivery/fpi.js?z=450117&width=300&height=250"></script> </center></div>
		</li></ul><!-- ends sidebar -->
</li><!-- ends belowadspot -->
</ul>
</li><!-- ends adspot -->
<li class="clear">&nbsp;</li>
</ul><!-- ends main -->
</div><!-- ends container -->

<div id="bottom"><!-- starts bottom -->
<ul id="bottom-wrapper">
<li id="bottomleft"><ul><li id="rss-7" class="widget widget_rss"><h2><a class="rsswidget" href="http://straightfromthea.com/category/atlanta-gossip/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://straightfromthea.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://straightfromthea.com/">Atlanta Gossip</a></h2><ul><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/22/pic-of-the-day-kim-porter-sarah-chapman-support-diddys-cant-stop-wont-stop-screening-photos/'>Pic of the Day! Kim Porter &amp; Sarah Chapman Support Diddy’s ‘Can’t Stop Won’t Stop’ Screening… (PHOTOS)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/22/whats-beef-porsha-williams-shades-nene-leakes-season-10-rhoa-return-video/'>What’s Beef! Porsha Williams Shades Nene Leakes’ Season 10 #RHOA Return… (VIDEO)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/20/are-t-i-tiny-reconciling-matching-outfits-late-night-booty-calls-could-be-clues-photos/'>Are T.I. &amp; Tiny Reconciling? Matching Outfits &amp; Late Night Booty Calls Could Be Clues… (PHOTOS)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/20/if-you-care-rhoa-kenya-moores-husband-revealed-photos/'>If You Care: #RHOA Kenya Moore’s ‘Husband’ Revealed… (PHOTOS)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/20/instagram-fail-fans-drag-marlo-hamptons-style-in-askmarlo-fashion-feature/'>Instagram Fail! Fans Drag Marlo Hampton’s Style in #ASKMarlo Fashion Feature…</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/20/case-dismissed-memphitz-dodges-prison-time-for-2015-car-wash-incident/'>Case Dismissed: MempHitz Dodges Prison Time For 2015 Car Wash Incident…</a></li></ul></li></ul></li>
<li id="bottommiddle"><ul><li id="text-459501719" class="widget widget_text">			<div class="textwidget"><p><center><!--JavaScript General Redirect Tag // Tag for network 10285: Marketplace: StraightFromTheA // Website: StraightFromTheA Desktop // Page: StraightFromTheA Desktop // Placement: StraightFromTheA 300x250 (3675420) // created at: Oct 28, 2015 3:46:50 PM--><br />
<script language="javascript1.1" src="https://adserver.adtechus.com/addyn|3.0|10285.1|3675420|0|170|ADTECH;loc=100;target=_blank;misc=[TIMESTAMP];rdclick="></script><br />
<!-- End of JavaScript Tag --></center></p>
</div>
		</li></ul></li>
<li id="bottomright"><ul><li id="rss-9" class="widget widget_rss"><h2><a class="rsswidget" href="http://straightfromthea.com/category/mugshot-mania/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://straightfromthea.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://straightfromthea.com/">Mugshot Mania</a></h2><ul><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/10/mugshot-mania-nick-gordon-arrested-for-beating-up-new-girlfriend/'>Mugshot Mania: Nick Gordon Arrested For Beating Up New Girlfriend…</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/08/mugshot-mania-meet-suspected-drug-dealer-who-was-busted-live-on-facebook-video/'>Mugshot Mania: Meet Suspected Drug Dealer Who Was Busted Live on Facebook… (VIDEO)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/06/05/mugshot-mania-comedian-mike-epps-reflects-on-criminal-past-photo/'>Mugshot Mania – Comedian Mike Epps Reflects on Criminal Past… (PHOTO)</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/05/31/mugshot-mania-rich-homie-quan-charged-with-felony-drug-possession/'>Mugshot Mania: Rich Homie Quan Charged With Felony Drug Possession…</a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/05/29/mugshot-mania-tiger-woods-arrested-for-suspicion-of-dui/'>Mugshot Mania: Tiger Woods Arrested For “Suspicion” of DUI… </a></li><li><a class='rsswidget' href='http://straightfromthea.com/2017/04/03/open-post-crack-smoking-homeless-man-blamed-for-atlanta-fire-bridge-collapse/'>OPEN POST: ‘Crack Smoking’ Homeless Man Blamed For Atlanta Fire &amp; Bridge Collapse… (PHOTOS + VIDEO)</a></li></ul></li></ul></li>
<li class="clear">&nbsp;</li>
</ul>
</div><!-- ends bottom -->

<div id="footer"><!-- starts footer -->
<br />
<center>
<!-- begin ad tag -->
<!-- SFTA_FooterAd_728x90 -->
<script type='text/javascript'>
GA_googleFillSlot("SFTA_FooterAd_728x90");
</script>
<!-- end ad tag -->
</center>
<center>
<a href="http://straightfromthea.com" title="Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News" style="color:#fff;">&copy; 2007 - 2017 Straight From The A [SFTA] &#8211; Atlanta Entertainment Industry Gossip &amp; News</a><br />
<br/>
<p class="credit" id="credit" itemprop="credit"><a class="credit-link" href="http://zillzdesignedit.com/" title="ZILLZDESIGNEDIT"><a href="http://zillzdesignedit.com/"><img src="http://straightfromthea.com/wp-content/uploads/2016/11/zillzdesignedit.png" alt="ZILLZDESIGNEDIT" width="70" height="45" class="alignnone size-full wp-image-204328" /></a></p>
<script id="_wau1b5">var _wau = _wau || []; _wau.push(["small", "47765hfex33c", "1b5"]);
(function() {var s=document.createElement("script"); s.async=true;
s.src="http://widgets.amung.us/small.js";
document.getElementsByTagName("head")[0].appendChild(s);
})();</script></center>
</div><!-- ends footer -->
        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'straightfromthea';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <!-- Powered by WPtouch Pro: 4.1.1 -->	<div style="display:none">
	</div>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/comment-reply.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"3061145.3a81a9f.a456e309e4e5448db5e454408653ad79"};
/* ]]> */
</script>
<script type='text/javascript' src='http://straightfromthea.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.9'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201725'></script>
<script type='text/javascript' src='http://straightfromthea.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201725.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.0',blog:'39327528',post:'215237',tz:'-4',srv:'straightfromthea.com'} ]);
	_stq.push([ 'clickTrackerInit', '39327528', '215237' ]);
</script>
<!-- Start Quantcast tag -->
<script type="text/javascript">
_qoptions={
qacct:"p-fbtLAmt-wiiPM"
};
</script>
<script type="text/javascript" src="https://www.quantserve.com/quant.js"></script>
<noscript>
<a href="http://www.quantcast.com/p-fbtLAmt-wiiPM" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-fbtLAmt-wiiPM.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></a>
</noscript>
<!-- End Quantcast tag -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5176916-1', 'auto');
  ga('send', 'pageview');

</script>
<script id="dsq-count-scr" src="//straightfromthea.disqus.com/count.js" async></script>
<script type="text/javascript" src="http://ads.ayads.co/ajs.php?zid=17562"></script>
<style>
.shareaholic-canvas {float:left;} .storycontent .shareaholic-canvas {float:none !important;}
</style>
</body>
</html>